freebsd-ports/sysutils/fusefs-ntfs/files/extra-patch-ublio
Julien Laffaye a5b68f24f9 Update to 2011.4.12
Do no install files outside PREFIX

PR:		ports/156615 (based on)
Submitted by:	bartoletti <coder@tuxfamily.org>
Approved by:	tabthorpe (mentor)
2011-07-10 16:29:38 +00:00

27 lines
1.1 KiB
Text

--- libntfs-3g/Makefile.in.orig 2011-04-10 20:04:51.000000000 +0200
+++ libntfs-3g/Makefile.in 2011-04-25 18:54:01.000000000 +0200
@@ -250,6 +250,7 @@
libntfs_3g_la_CFLAGS = $(AM_CFLAGS) -I$(top_srcdir)/include/ntfs-3g
libntfs_3g_la_LDFLAGS = -version-info $(LIBNTFS_3G_VERSION) -no-undefined
@FUSE_INTERNAL_TRUE@libntfs_3g_la_LIBADD = $(top_builddir)/libfuse-lite/libfuse-lite.la
+libntfs_3g_la_LIBADD = -lublio
libntfs_3g_la_SOURCES = acls.c attrib.c attrlist.c bitmap.c bootsect.c \
cache.c collate.c compat.c compress.c debug.c device.c dir.c \
efs.c index.c inode.c lcnalloc.c logfile.c logging.c mft.c \
--- src/ntfs-3g.c.orig 2011-04-10 20:04:41.000000000 +0200
+++ src/ntfs-3g.c 2011-04-25 18:56:07.000000000 +0200
@@ -3262,9 +3262,13 @@
#else
.utime = ntfs_fuse_utime,
#endif
+#ifndef __FreeBSD__
+ .bmap = ntfs_fuse_bmap,
+#else
+ .bmap = NULL,
+#endif
.fsync = ntfs_fuse_fsync,
.fsyncdir = ntfs_fuse_fsync,
- .bmap = ntfs_fuse_bmap,
.destroy = ntfs_fuse_destroy2,
#if !KERNELPERMS | (POSIXACLS & !KERNELACLS)
.access = ntfs_fuse_access,