freebsd-ports/lang/ratfor/files/patch-Makefile
Tijl Coosemans 564a799c71 Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though.

Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk.

Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,...

Exp-run:	bdrewery
Approved by:	portmgr (bdrewery)
2014-02-16 17:15:31 +00:00

31 lines
636 B
Text

--- Makefile.orig 2013-11-16 17:28:28.000000000 +0100
+++ Makefile 2013-11-16 17:27:51.000000000 +0100
@@ -11,7 +11,7 @@
# On GNU, use S_CHAR="char"
#
-CFLAGS+= -DF77 -DS_CHAR="char"
+CFLAGS+= -DF77 -DS_CHAR="char" -Wno-error=return-type
#CFLAGS+= -DS_CHAR="char"
OBJS= rat4.o lookup.o getopt.o
@@ -26,13 +26,15 @@
clean:
rm -f *.o *~ ratfor ratfor77 a.out test testw test.f testw.f
-test: ratfor
+test: test.f
+
+test.f: ratfor
./ratfor -o test.f test.r
- f77 -o test test.f
-testw: ratfor
+testw: testw.f
+
+testw.f: ratfor
./ratfor -o testw.f testw.r
- f77 -o testw testw.f
tests: test testw
./test