freebsd-ports/multimedia/vdr-plugin-control/files/patch-Makefile
Juergen Lock 47452dcb43 - Finally stagify the vdr ports. \o/
- Use new LIB_DEPENDS syntax.
- Change multimedia/vdr-plugins defaults and bump PORTREVISION for it.
  (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
2014-03-01 12:21:13 +00:00

23 lines
673 B
Text

--- a/Makefile
+++ b/Makefile
@@ -29,6 +29,8 @@ TMPDIR = /tmp
-include $(VDRDIR)/Make.config
+CXXFLAGS += -Wno-error=overloaded-virtual
+
### The version number of VDR (taken from VDR's "config.h"):
VDRVERSION = $(shell grep 'define VDRVERSION ' $(VDRDIR)/config.h | awk '{ print $$3 }' | sed -e 's/"//g')
@@ -67,6 +67,11 @@ dist: clean
clean:
@-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
+APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
+
+install:
+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
+
### Implicit rules:
%.o: %.c