freebsd-ports/emulators/virtualbox-ose/files/patch-src-VBox-GuestHost-OpenGL-Makefile.kmk
Jung-uk Kim b8592bbae4 - Reduce diff from Linux OpenGL support. Note we do not have to manually
turn off AIGLX any more.
- Do not install vboxvideo.ko when OPENGL is disabled.  It is only required
for OpenGL support.
- Install vboxvideo.ko.symbols when both DEBUG and OPENGL are enabled.
- Do not try to load vboxvideo.ko if it does not exist.
2014-12-23 00:05:04 +00:00

20 lines
711 B
Text

--- src/VBox/GuestHost/OpenGL/Makefile.kmk.orig 2014-11-21 10:22:21.000000000 -0500
+++ src/VBox/GuestHost/OpenGL/Makefile.kmk 2014-12-22 17:20:31.000000000 -0500
@@ -116,7 +116,7 @@
endif
VBoxOGLcrutil_CLEAN = \
$(VBOX_PATH_CROGL_GENFILES)/debug_opcodes.c
-if1of ($(KBUILD_TARGET), linux)
+if1of ($(KBUILD_TARGET), linux freebsd)
VBoxOGLcrutil_LDFLAGS += -Wl,-z,nodelete
endif
@@ -160,7 +160,7 @@
if defined(VBOX_SIGNING_MODE) && defined(VBOX_WITH_WDDM)
VBoxOGLhostcrutil_INSTTYPE.win = both
endif
-if1of ($(KBUILD_TARGET), linux)
+if1of ($(KBUILD_TARGET), linux freebsd)
VBoxOGLhostcrutil_LDFLAGS = $(NO_SUCH_VARIABLE)
endif
VBoxOGLhostcrutil_LDFLAGS.darwin = $(VBoxOGLcrutil_LDFLAGS.darwin) \