freebsd-ports/games/cleanq3/files/patch-code-qcommon-common.c
Alejandro Pulver 4c345ed272 - Bump PORTREVISION.
- Use Makefile for building instead of scons, and remove Perl dependency.
- Use pkg-plist.
- Add OPTIONS. Allow to build without X11, threaded version, etc.
- Fix building on non-i386 and FreeBSD 4.X.
- Respect CFLAGS when optimizations are enabled.
- Add patch to fix 2 security vulnerabilities [1].

PR:		ports/98295
Submitted by:	alepulver (myself)
Approved by:	maintainer (timeout)
Obtained from:	q3icculus (http://icculus.org/quake3/) [1]
Security:	CVE-2006-2082 [1]
2006-07-23 18:56:26 +00:00

28 lines
595 B
C

--- ./code/qcommon/common.c.orig Wed May 31 20:52:07 2006
+++ ./code/qcommon/common.c Wed May 31 20:52:09 2006
@@ -24,15 +24,8 @@
#include "../game/q_shared.h"
#include "qcommon.h"
#include <setjmp.h>
-#ifdef __linux__
-#include <netinet/in.h>
-#else
-#if defined(MACOS_X)
+#include <sys/types.h>
#include <netinet/in.h>
-#else
-#include <winsock.h>
-#endif
-#endif
int demo_protocols[] =
{ 66, 67, 68, 0 };
@@ -2367,7 +2360,7 @@
// cvar and command buffer management
Com_ParseCommandLine( commandLine );
-// Swap_Init ();
+ Swap_Init ();
Cbuf_Init ();
Com_InitZoneMemory();