freebsd-ports/math/octave-forge-fenv/files/patch-src_Makefile
Sylvio Cesar Teixeira ad97a8683c The octave-forge package is the result of the GNU Octave Repositry project, which is intended to be a central location for custom scripts, funcitons and extensions for GNU Octave, contains the source for all the functions plus build and install scripts.
This is fenv.

On supported architectures, change the rounding mode of the floating point arithmetics (to nearest, up, down, to zero) or change the precision of the test the properties of the floating point arithmetics.

WWW:	http://octave.sourceforge.net/

PR:		ports/147601
Submitted by:	Stephen Montgomery-Smith <stephen@missouri.edu>
Feature safe:	yes
2010-06-29 12:03:07 +00:00

17 lines
427 B
Text

--- Makefile-orig 2010-06-06 16:11:01.000000000 -0500
+++ Makefile 2010-06-06 16:11:17.000000000 -0500
@@ -1,13 +1,10 @@
-include configure.in # This file is automatically generated by
- # ../pre_install.m and sets FENV_OPTS
-
OCT = fe_system_dependent.oct
SRC := $(OCT:.oct=.cc)
all: $(OCT)
fe_system_dependent: $(OCT)
-%.oct: %.cc configure.in Makefile
+%.oct: %.cc Makefile
mkoctfile -s $< $(FENV_OPTS)