freebsd-ports/www/firefox35/files/patch-config-rules.mk
Peter Wemm 7059589bd6 Port to amd64 (note: needs ld-elf.so.1 bugfix to actually work)
I've taken a chance and split the sparc64 and alpha mega-diffs up because
sparc64 patched the result of alpha's patches, and amd64 needed to do the
same again - but it was sorted lexically before alpha/sparc64.  I've
grouped the xptcall patches together since they are standalone and split
up and merged the other infrastructure jumbo-patches.

I also attempted to sync up the nspr vs firebird diffs for sparc64 and
alpha because they disagreed.  HOWEVER... While this port 'depends'
on the nspr port, it doesn't actually *use* it.  It should probably
be removed from the LIB_DEPENDS list.

Note that the amd64 xptcall code came from SuSE via the mozilla bugzilla
database.
2003-12-13 21:35:43 +00:00

14 lines
307 B
Makefile

--- config/rules.mk.orig Mon May 5 21:04:55 2003
+++ config/rules.mk Tue May 27 01:33:11 2003
@@ -444,7 +444,11 @@
ifeq ($(OS_ARCH),FreeBSD)
ifdef IS_COMPONENT
+ifneq (,$(filter alpha,$(OS_TEST)))
+EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic -lc
+else
EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
+endif
endif
endif