freebsd-ports/graphics/nvidia-texture-tools/files/patch-src-nvtt-CMakeLists.txt
Dmitry Marakasov 464602e87a The NVIDIA Texture Tools is a collection of image processing and
texture manipulation tools, designed to be integrated in game tools
and asset conditioning pipelines.

The primary features of the library are mipmap and normal map
generation, format conversion and DXT compression.

DXT compression is based on Simon Brown's squish library. The library
also contains an alternative GPU-accelerated compressor that uses
CUDA and is one order of magnitude faster.

WWW: http://code.google.com/p/nvidia-texture-tools/
2009-03-07 14:51:39 +00:00

15 lines
504 B
Text

--- src/nvtt/CMakeLists.txt.orig 2008-12-01 11:04:29.000000000 +0300
+++ src/nvtt/CMakeLists.txt 2009-03-06 22:58:45.000000000 +0300
@@ -105,9 +105,11 @@
QT4_WRAP_CPP(MOCS tools/configdialog.h)
#QT4_ADD_RESOURCES(RCCS tools/configdialog.rc)
- ADD_EXECUTABLE(nvcompressui MACOSX_BUNDLE ${SRCS} ${UICS} ${MOCS})
+ ADD_EXECUTABLE(nvcompressui ${SRCS} ${UICS} ${MOCS})
TARGET_LINK_LIBRARIES(nvcompressui ${LIBS})
+ INSTALL(TARGETS nvcompressui DESTINATION bin)
+
ENDIF(QT4_FOUND AND NOT MSVC)