freebsd-ports/multimedia/exportvideo/files/patch-libmpeg3_Makefile
Pav Lucistnik 3c844061b7 Add exportvideo, an utility extracts the video data from a nuppelvideo
file and writes a YUV4MPEG stream which can be piped to mpeg2enc.
In other words, it exports the nuppelvideo .nuv format for encoding
(S)VCD/DVD compliant MPEGs with mjpegtools.

PR:		ports/73417
Submitted by:	Frank W. Josellis <frank@dynamical-systems.org>
2004-11-06 20:17:06 +00:00

22 lines
447 B
Text

--- libmpeg3/Makefile.orig Thu Mar 8 01:11:07 2001
+++ libmpeg3/Makefile Mon Nov 1 09:41:06 2004
@@ -44,7 +44,7 @@
OUTPUT = libmpeg3.a
UTILS = dump mpeg3cat mpeg3toc mpeg3split
-LIBS = -lm -lpthread
+LIBS = -lm -pthread
all: $(OUTPUT) util
@@ -71,8 +71,8 @@
$(CC) -c `./c_flags` $*.c
clean:
- make -C audio clean
- make -C video clean
+ $(MAKE) -C audio clean
+ $(MAKE) -C video clean
rm -f core *.o $(OUTPUT)
rm -f $(UTILS)