e332617a7d
- TCG support (No longer requires GCC 3.x) - Kernel Virtual Machine acceleration support [kernel bits not ported to FreeBSD yet] - BSD userspace emulation [untested on FreeBSD, probably doesn't work at least for i386 hosts] - Bluetooth emulation and host passthrough support [not ported to FreeBSD yet] - GDB XML register description support - Intel e1000 emulation - HPET emulation - VirtIO paravirtual device support - Marvell 88w8618 / MusicPal emulation - Nokia N-series tablet emulation / OMAP2 processor emulation - PCI hotplug support - Live migration and new save/restore formats - Curses display support - qemu-nbd utility to mount supported block formats [not ported to FreeBSD yet] - Altivec support in PPC emulation and new firmware (OpenBIOS) - Multiple VNC clients are now supported - TLS encryption is now supported in VNC - MIPS Magnum R4000 machine (Herve Poussineau) - Braille support (Samuel Thibault) - Freecom MusicPal system emulation (Jan Kiszka) - OMAP242x and Nokia N800, N810 machines (Andrzej Zaborowski) - EsounD audio driver (Frederick Reeve) - Gravis Ultrasound GF1 sound card (Tibor "TS" Schuetz) - Many, many, bug fixes and new features
57 lines
1.1 KiB
Text
57 lines
1.1 KiB
Text
Index: qemu/bsd/Makefile
|
|
@@ -16,7 +16,8 @@
|
|
${MACHINE_ARCH}/s_rintl.c \
|
|
${MACHINE_ARCH}/s_round.c \
|
|
${MACHINE_ARCH}/s_sinl.S \
|
|
- ${MACHINE_ARCH}/s_tanl.S
|
|
+ ${MACHINE_ARCH}/s_tanl.S \
|
|
+ ${MACHINE_ARCH}/s_ldexpl.c
|
|
|
|
OBJS= ${SRCS:R:S/$/.o/}
|
|
|
|
Index: qemu/bsd/i386/s_ldexpl.c
|
|
@@ -0,0 +1,21 @@
|
|
+#include <math.h>
|
|
+#include <errno.h>
|
|
+#include <sysdep.h>
|
|
+
|
|
+long double __ldexpl(long double x, int expn)
|
|
+{
|
|
+ long double res;
|
|
+ if (!isfinite (x) || x == 0.0L)
|
|
+ return x;
|
|
+
|
|
+ __asm__ ("fscale"
|
|
+ : "=t" (res)
|
|
+ : "0" (x), "u" ((long double) expn));
|
|
+
|
|
+ if (!isfinite (res) || res == 0.0L)
|
|
+ errno = ERANGE;
|
|
+
|
|
+ return res;
|
|
+}
|
|
+
|
|
+weak_alias(__ldexpl,ldexpl)
|
|
Index: qemu/bsd/amd64/s_ldexpl.c
|
|
@@ -0,0 +1,21 @@
|
|
+#include <math.h>
|
|
+#include <errno.h>
|
|
+#include <sysdep.h>
|
|
+
|
|
+long double __ldexpl(long double x, int expn)
|
|
+{
|
|
+ long double res;
|
|
+ if (!isfinite (x) || x == 0.0L)
|
|
+ return x;
|
|
+
|
|
+ __asm__ ("fscale"
|
|
+ : "=t" (res)
|
|
+ : "0" (x), "u" ((long double) expn));
|
|
+
|
|
+ if (!isfinite (res) || res == 0.0L)
|
|
+ errno = ERANGE;
|
|
+
|
|
+ return res;
|
|
+}
|
|
+
|
|
+weak_alias(__ldexpl,ldexpl)
|