445b5c3a24
PR: 123871 Submitted by: Ports Fury
58 lines
1.4 KiB
Text
58 lines
1.4 KiB
Text
--- spim/Makefile.orig 2006-08-29 11:23:19.000000000 +0900
|
|
+++ spim/Makefile 2008-04-23 01:36:01.000000000 +0900
|
|
@@ -54,13 +54,13 @@
|
|
|
|
|
|
# Full path for the directory that will hold the executable files:
|
|
-BIN_DIR = /usr/local/bin
|
|
+BIN_DIR = ${PREFIX}/bin
|
|
|
|
# Full path for the directory that will hold the exception handler:
|
|
-EXCEPTION_DIR = /usr/local/lib
|
|
+EXCEPTION_DIR = ${PREFIX}/share/spim
|
|
|
|
# Full path for the directory that will hold the man files:
|
|
-MAN_DIR = /usr/man/mann
|
|
+MAN_DIR = ${PREFIX}/man/man1
|
|
|
|
|
|
# If you have flex, use it instead of lex. If you use flex, define this
|
|
@@ -92,12 +92,12 @@
|
|
|
|
DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_EXCEPTION_HANDLER="\"$(EXCEPTION_DIR)/exceptions.s\"" -DSPIM_VERSION="\"`cat ../VERSION`\""
|
|
|
|
-CC = gcc
|
|
-CFLAGS = -I. -I$(CPU_DIR) $(DEFINES) -g -Wall
|
|
-YFLAGS = -d --file-prefix=y
|
|
+CC? = gcc
|
|
+CFLAGS += -I. -I$(CPU_DIR) $(DEFINES) -Wall
|
|
+YFLAGS = -d
|
|
YCFLAGS =
|
|
LDFLAGS = -lm
|
|
-CSH = bash
|
|
+CSH = csh
|
|
|
|
# lex.yy.c is usually compiled with -O to speed it up.
|
|
|
|
@@ -110,10 +110,10 @@
|
|
|
|
|
|
spim: force
|
|
- make -f Makefile spim2
|
|
+ $(MAKE) -f Makefile spim2
|
|
|
|
spim2: $(OBJS) spim.o
|
|
- $(CC) -g $(OBJS) spim.o $(LDFLAGS) -o spim -lm
|
|
+ $(CC) $(OBJS) spim.o $(LDFLAGS) -o spim -lm
|
|
|
|
|
|
force: configuration
|
|
@@ -196,7 +196,7 @@
|
|
y.tab.h: y.tab.c
|
|
|
|
y.tab.c: $(CPU_DIR)/parser.y
|
|
- bison $(YFLAGS) $(CPU_DIR)/parser.y
|
|
+ yacc $(YFLAGS) $(CPU_DIR)/parser.y
|
|
|
|
y.tab.o: y.tab.c
|
|
$(CC) $(CFLAGS) $(YCFLAGS) -c y.tab.c
|