freebsd-ports/games/goonies/files/patch-build-linux-Makefile
Tijl Coosemans 216b5a285f - Fix missing library problems when the linker enforces explicit linking
PR:		192062
Exp-run by:	antoine
Approved by:	portmgr (antoine)
2014-08-26 14:06:08 +00:00

21 lines
748 B
Text

--- build/linux/Makefile.orig Mon Aug 28 15:10:27 2006
+++ build/linux/Makefile Thu Sep 7 00:20:01 2006
@@ -25,13 +25,13 @@
TheGoonies.o TheGooniesApp.o main.o
EXE = goonies
-INSTDIR = /usr/local/games/$(EXE)
-STARTUP = /usr/local/bin/$(EXE)
+INSTDIR = ${DATADIR}
+STARTUP = ${PREFIX}/bin/$(EXE)
DATA = ../graphics ../maps ../sound
-CC = c++
-CFLAGS = -g3 -O3 -Wall `sdl-config --cflags` -I/usr/local/include/SDL -I/usr/X11R6/include
-LDFLAGS = `sdl-config --libs` -L/usr/X11R6/lib/ -lSDL_image -lSDL_mixer -lSDL_sound -lGL -lGLU
+CC ?= c++
+CFLAGS += -Wall `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
+LDFLAGS += `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib -lSDL_image -lSDL_mixer -lGL -lGLU -lm
RM = rm -f
CP = cp -r
LN = ln -s