freebsd-ports/games/meqcc/files/patch-cmdlib.c
Alexey Dokuchaev a9aa1882ce - Fix the build with Clang [*]
- Remove defunct address from MASTER_SITES
- Use USE_DOS2UNIX instead of hand-rolled routine
- Define LICENSE (GPLv2)
- Remove USE_GMAKE, does not seem to be needed
- Do not patch files with both patch(1) and sed(1): when patch file already
  exists, augment it and remove corresponding REINPLACE_CMD
- Convert pkg-plist into PLIST_FILES and PORTDOCS, remove useless file
- Remove superfluous backslashes in sed(1) expressions, do minor cleanups

Submitted by:	Cyril Roelandt [*]
2012-02-06 16:06:17 +00:00

20 lines
327 B
C

--- cmdlib.c.orig Sat Jan 15 20:08:10 2005
+++ cmdlib.c Sat Jan 15 20:03:02 2005
@@ -5,7 +5,7 @@
#include "cmdlib.h"
#include <time.h>
-#include <io.h>
+#include <unistd.h>
#define PATHSEPERATOR '/'
@@ -141,6 +141,8 @@
================
*/
// MrE:
+long int tell (int);
+
long int filelength (int handle)
{
/*