* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
30 lines
934 B
C
30 lines
934 B
C
--- base/gdevl256.c.orig 2007-09-25 22:31:24.000000000 +0900
|
|
+++ base/gdevl256.c 2010-08-01 23:05:56.000000000 +0900
|
|
@@ -143,9 +143,12 @@
|
|
/* for compatibility with the older display modes: */
|
|
/* these are indexed as 0.0.R0.G0.B0.R1.G1.B1. */
|
|
gx_color_index
|
|
-lvga256_map_rgb_color(gx_device * dev, gx_color_value r, gx_color_value g,
|
|
- gx_color_value b)
|
|
+lvga256_map_rgb_color(gx_device * dev, const gx_color_value cv[])
|
|
{
|
|
+ gx_color_value r = cv[0];
|
|
+ gx_color_value g = cv[1];
|
|
+ gx_color_value b = cv[2];
|
|
+
|
|
#define cv_bits(v,n) (v >> (gx_color_value_bits - n))
|
|
ushort r5 = cv_bits(r, 5), g5 = cv_bits(g, 5), b5 = cv_bits(b, 5);
|
|
static const byte cube_bits[32] =
|
|
@@ -301,12 +304,3 @@
|
|
gl_line(x0, y0, x1, y1, color);
|
|
return 0;
|
|
}
|
|
-
|
|
-#ifdef GS_DEVS_SHARED
|
|
-extern void gs_lib_register_device(const gx_device *dev);
|
|
-void
|
|
-gs_shared_init(void)
|
|
-{
|
|
- gs_lib_register_device(&gs_lvga256_device);
|
|
-}
|
|
-#endif
|