* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
11 lines
447 B
C
11 lines
447 B
C
--- base/gdevperm.c.orig Tue Sep 25 22:31:24 2007
|
|
+++ base/gdevperm.c Sat Nov 24 15:11:12 2007
|
|
@@ -286,7 +286,7 @@
|
|
(strncmp((const char *)name, (const char *)str, name_size) == 0))
|
|
|
|
static int
|
|
-perm_get_color_comp_index(const gx_device *pdev, const char *pname,
|
|
+perm_get_color_comp_index(gx_device *pdev, const char *pname,
|
|
int name_size, int component_type)
|
|
{
|
|
const gx_device_perm_t * const dev = (const gx_device_perm_t *)pdev;
|