freebsd-ports/games/pipenightdreams/files/patch-src__list.cpp
Rusmir Dusko 0230fbbab4 - Bump PORTREVISION
- Take maintainership
- Remove leading article from COMMENT
- Add license (GPLv2)
- USES gmake instead of USE_GMAKE
- Disable all warnings with -w
- Support STAGEDIR
- Add DOCS and Option
- Add Desktop entry file
- Add and symlink the icon
- Recreate patches with make makepatch
- Recreate pkg-plist with make makeplist

PR:		ports/173880
Submitted by:	nemysis (self)
2014-02-02 00:20:09 +00:00

20 lines
522 B
C++

--- ./src/list.cpp.orig 2002-01-17 20:56:35.000000000 +0100
+++ ./src/list.cpp 2014-02-01 23:41:06.000000000 +0100
@@ -125,7 +125,7 @@
return (insert(indexOf(i), obj));
}
-List::Result List::remove(Index * index, bool del=false){
+List::Result List::remove(Index * index, bool del){
if (isEmpty()) return EmptyList;
if (!index) return NullIndex;
@@ -155,7 +155,7 @@
return Removed;
}
-void List::empty(bool del=true){
+void List::empty(bool del){
while (!isEmpty())
remove(getFirst(), del);
}