freebsd-ports/www/py-libsass/files/patch-setup.py
Yuri Victorovich ea3e9b8ee4 www/py-libsass: fix build with GCC-based architectures
PR:		233691
Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl>
2018-12-01 16:31:17 +00:00

14 lines
464 B
Python

--- setup.py.orig 2018-12-01 15:27:12 UTC
+++ setup.py
@@ -18,9 +18,9 @@ MACOS_FLAG = ['-mmacosx-version-min=10.7']
FLAGS_POSIX = [
'-fPIC', '-std=gnu++0x', '-Wall', '-Wno-parentheses', '-Werror=switch',
]
-FLAGS_CLANG = ['-c', '-O3'] + FLAGS_POSIX + ['-stdlib=libc++']
+FLAGS_CLANG = ['-c'] + FLAGS_POSIX
LFLAGS_POSIX = ['-fPIC', '-lstdc++']
-LFLAGS_CLANG = ['-fPIC', '-stdlib=libc++']
+LFLAGS_CLANG = ['-fPIC']
sources = ['pysass.cpp']
headers = []