freebsd-ports/net/p5-Net-Z3950/files/patch-yazwrap-Makefile.PL
Dmitry Sivachenko c5247eba15 Fix build with ancient version of perl (5.005).
Pointed out by:		kris
2003-09-19 07:03:18 +00:00

19 lines
602 B
Perl

--- yazwrap/Makefile.PL.orig Tue May 6 17:59:59 2003
+++ yazwrap/Makefile.PL Fri Sep 19 10:57:34 2003
@@ -1,8 +1,15 @@
+my $yazinc = `yaz-config --cflags`;
+my $yazlibs = `yaz-config --libs`;
+if (!$yazinc || !$yazlibs) {
+ die "ERROR: Unable to call script 'yaz-config': is YAZ installed?";
+}
+
use ExtUtils::MakeMaker;
-$Verbose = 1;
WriteMakefile(
'NAME' => 'Net::Z3950::yazwrap',
+ 'LIBS' => [ $yazlibs ],
+ 'INC' => $yazinc,
'SKIP' => [qw(all static dynamic test)],
'clean' => {'FILES' => 'libyazwrap$(LIB_EXT)'},
'OPTIMIZE' => '-g', ### temporary