28 lines
792 B
Text
28 lines
792 B
Text
|
|
$FreeBSD$
|
|
|
|
--- ROX-Filer/src/configure.in.orig
|
|
+++ ROX-Filer/src/configure.in
|
|
@@ -2,11 +2,6 @@
|
|
AC_INIT(main.c)
|
|
AC_CONFIG_HEADER(config.h)
|
|
|
|
-[ if [ -f configure ]; then ]
|
|
- AC_MSG_ERROR([Please run configure from the build directory (try ../AppRun --compile)])
|
|
- exit 1
|
|
-fi
|
|
-
|
|
dnl Checks for programs.
|
|
AC_PROG_CC
|
|
|
|
@@ -127,10 +122,6 @@
|
|
AC_HEADER_STDC
|
|
AC_HEADER_SYS_WAIT
|
|
AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h mntent.h sys/ucred.h sys/mntent.h apsymbols.h apbuild/apsymbols.h sys/statvfs.h sys/vfs.h wctype.h)
|
|
-
|
|
-AC_CHECK_HEADER([X11/SM/SMlib.h], [],
|
|
- [AC_MSG_ERROR([Session management library (libsm) missing. It is part of the X server distribution. Try installing the libsm-dev package.])]
|
|
-)
|
|
|
|
dnl Checks for typedefs, structures, and compiler characteristics.
|
|
AC_C_CONST
|