Upgrading from Ice 3.6 isn't trivial, as it requires application code changes. Therefore a new set of ports was created. Marked devel/{ice|php5-ice|py-ice} as conflicting (and vice versa). PR: 221141
13 lines
819 B
Makefile
13 lines
819 B
Makefile
--- python/modules/IcePy/Makefile.mk.orig 2018-04-20 15:02:08 UTC
|
|
+++ python/modules/IcePy/Makefile.mk
|
|
@@ -14,8 +14,8 @@ IcePy_targetname := IcePy
|
|
IcePy_targetdir := $(lang_srcdir)/python
|
|
IcePy_installdir := $(install_pythondir)
|
|
IcePy_cppflags := -I$(project) $(ice_cpp_cppflags) -I$(top_srcdir)/cpp/src $(python_cppflags)
|
|
-IcePy_system_libs := $(python_ldflags)
|
|
-IcePy_dependencies := IceDiscovery IceLocatorDiscovery IceSSL Ice
|
|
+IcePy_system_libs := $(python_ldflags) -lIceDiscovery -lIceLocatorDiscovery -lIceSSL -lIce
|
|
+#IcePy_dependencies := IceDiscovery IceLocatorDiscovery IceSSL Ice
|
|
IcePy_libs := mcpp
|
|
IcePy_extra_sources := $(filter-out %Util.cpp %Ruby.cpp,\
|
|
$(wildcard $(top_srcdir)/cpp/src/Slice/*.cpp)) \
|