freebsd-ports/graphics/utah-glx/files/patch-ab
Maxim Sobolev 663a202941 Update to the latest cvs snapshot.
- New chipset supported: S3 Savage3D (I have not tested it personally);
- Improved support for already supported chipsets;
- Change port versioning scheme to PORTVERSION=YYYYMMDD, because despite the
  promise, the project had not released its magic 1.0 version (promised to be
  about 3 months ago);
- Catch change of the Mesa3 version.
2000-08-25 09:27:55 +00:00

39 lines
1.5 KiB
Text

--- libGLU/Makefile.in.orig Thu Aug 24 16:53:46 2000
+++ libGLU/Makefile.in Thu Aug 24 21:42:43 2000
@@ -13,10 +13,10 @@
# These define the name/version of the shared library we're building
# ------------------------------------------------------------------
LIBNAME = GLU
-GLUREV_major = 1
-GLUREV_minor = 2
-GLUREV_micro = 0
-SOGLUREV = ${GLUREV_major}.${GLUREV_minor}.${GLUREV_micro}
+GLUREV_major = ${GLVER}
+GLUREV_minor =
+GLUREV_micro =
+SOGLUREV = ${GLUREV_major}
GLULIB = lib${LIBNAME}.so.${SOGLUREV}
# FIXME: different library version for Mesa 3.2?
@@ -104,8 +104,8 @@
@if [ -d ${DESTDIR}${INSTALL_libdir} ]; then set +x; \
else (set -x; ${MKDIR} ${DESTDIR}${INSTALL_libdir}); fi
${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLULIB} ${DESTDIR}${INSTALL_libdir}
- ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
- ${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
+# ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
+# ${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so ;\
${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so
else
@@ -135,8 +135,8 @@
fi;
${RM} $@
${MV} $@~ $@
- ${RM} lib${LIBNAME}.so.${GLUREV_major}
- ${LN} $@ lib${LIBNAME}.so.${GLUREV_major}
+# ${RM} lib${LIBNAME}.so.${GLUREV_major}
+# ${LN} $@ lib${LIBNAME}.so.${GLUREV_major}
${RM} lib${LIBNAME}.so
${LN} $@ lib${LIBNAME}.so