freebsd-ports/www/mod_dnssd/files/patch-src__Makefile.in
Kurt Jaeger 651c415d78 www/mod_dnssd: fix build with apache22
Requested by:	Wolfgang Riegler <wolfgang.riegler@gmx.de>
Submitted by:	olli hauer <ohauer@gmx.de>
2016-01-26 19:59:29 +00:00

24 lines
619 B
Text

--- src/Makefile.in.orig 2009-01-22 16:42:02 UTC
+++ src/Makefile.in
@@ -15,9 +15,10 @@
# permissions and limitations under the License.
APXS=@APXS@
+APXS_STAGE=@APXS_STAGE@
APACHECTL=@APACHECTL@
-LIBS=-Wl,"@LIBS@" @AVAHI_LIBS@
-CFLAGS=-Wc,"@CFLAGS@" @AVAHI_CFLAGS@
+LIBS=-Wl,"@LIBS@ @AVAHI_LIBS@"
+CFLAGS=-Wc,"@CFLAGS@ @AVAHI_CFLAGS@"
all: mod_dnssd.la
@@ -25,7 +26,7 @@ mod_dnssd.la: @srcdir@/mod_dnssd.c
$(APXS) -c $(CFLAGS) $(LIBS) @srcdir@/mod_dnssd.c
install: all
- $(APXS) -i -a mod_dnssd.la
+ $(APXS) $(APXS_STAGE) -i mod_dnssd.la
clean:
rm -rf *.o *.so *.loT .deps/ *.la *.lo *.slo .libs/