4f960ddb6b
- Disable PCH (precompiled header) to unbreak build with GCC in jails for older branches and recent 11.0C kernel - Add upstream patch for bundled libenet to unbreak build on DragonFly [1] - Convert patch for ${BUILD_WRKSRC}/Makefile into sed(1) variant - Pet portlint since r383894 by formatting patches with makepatch target PR: 199912 Submitted by: lightside <lightside@gmx.com> (maintainer) Obtained from: https://github.com/lsalzman/enet/commit/8df6e58 [1]
11 lines
417 B
C++
11 lines
417 B
C++
--- source/src/master.cpp.orig 2013-10-09 08:27:37 UTC
|
|
+++ source/src/master.cpp
|
|
@@ -510,7 +510,7 @@
|
|
authreq &a = c.authreqs.add();
|
|
a.reqtime = servtime;
|
|
a.id = id;
|
|
- uint seed[3] = { starttime, servtime, randomMT() };
|
|
+ uint seed[3] = { (uint)starttime, servtime, randomMT() };
|
|
static vector<char> buf;
|
|
buf.setsize(0);
|
|
a.answer = genchallenge(u->pubkey, seed, sizeof(seed), buf);
|