freebsd-ports/japanese/tkstep80/files/patch-ab
Ade Lovett ce345d84aa Update to 8.0.5
PR:		21077
Submitted by:	maintainer
2000-09-16 19:23:22 +00:00

192 lines
7.2 KiB
Text

--- Makefile.in.orig Wed Sep 6 16:29:30 2000
+++ Makefile.in Wed Sep 6 17:04:19 2000
@@ -56,7 +56,9 @@
BIN_DIR = $(exec_prefix)/bin
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include/tkstep$(VERSION)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
+UNIX_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/unix
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -72,6 +74,9 @@
# Tcl commands implemented by Tk:
MANN_INSTALL_DIR = $(MAN_INSTALL_DIR)/mann
+# Directory in which to install sharedable other documents:
+DOC_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/share/doc/tk$(VERSION)
+
# The directory containing the Tcl sources and headers appropriate
# for this version of Tk ("srcdir" will be replaced or has already
# been replaced by the configure script):
@@ -113,7 +118,7 @@
# Libraries to use when linking. This definition is determined by the
# configure script.
-LIBS = @TCL_BUILD_LIB_SPEC@ @LIBS@ $(X11_LIB_SWITCHES) @DL_LIBS@ @MATH_LIBS@ @EXTRA_LIBS@
+LIBS = @TCL_LIB_SPEC@ @LIBS@ $(X11_LIB_SWITCHES) @DL_LIBS@ @MATH_LIBS@ @EXTRA_LIBS@
# To turn off the security checks that disallow incoming sends when
# the X server appears to be insecure, reverse the comments on the
@@ -149,7 +154,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
-INSTALL = @srcdir@/install-sh -c
+INSTALL = install -c
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -162,6 +167,8 @@
TK_SHLIB_CFLAGS = @TK_SHLIB_CFLAGS@
TK_LIB_FILE = @TK_LIB_FILE@
+TCL_L10N = @TCL_L10N@
+TK_STATIC_LIB_FILE = libtkstep80$(TCL_L10N).a
#TK_LIB_FILE = libtk.a
TK_LIB_FLAG = @TK_LIB_FLAG@
@@ -335,6 +342,14 @@
rm -f ${TK_LIB_FILE}
@MAKE_LIB@
$(RANLIB) ${TK_LIB_FILE}
+.if ${PORTOBJFORMAT}X == elfX
+ ln -sf ${TK_LIB_FILE} `echo ${TK_LIB_FILE} | sed 's/\.so.*$$/.so/'`
+.endif
+
+$(TK_STATIC_LIB_FILE): $(OBJS)
+ rm -f $(TK_STATIC_LIB_FILE)
+ ar cr $(TK_STATIC_LIB_FILE) $(OBJS)
+ $(RANLIB) $(TK_STATIC_LIB_FILE)
# Make target which outputs the list of the .o contained in the Tk lib
# usefull to build a single big shared library containing Tcl/Tk and other
@@ -384,13 +399,13 @@
TK_LIBRARY=$(TOP_DIR)/library; export TK_LIBRARY; \
./tktest
-install: install-binaries install-libraries install-demos install-demosjp install-man
+install: install-binaries install-libraries install-demos install-demosjp
# Note: before running ranlib below, must cd to target directory because
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
-install-binaries: $(TK_LIB_FILE) wish@STEP@
+install-binaries: $(TK_LIB_FILE) $(TK_STATIC_LIB_FILE) wish@STEP@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -404,13 +419,22 @@
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_LIB_FILE))
@chmod 555 $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
+.if ${PORTOBJFORMAT}X == elfX
+ @(cd $(LIB_INSTALL_DIR); ln -sf ${TK_LIB_FILE} `echo ${TK_LIB_FILE} | sed 's/\.so.*$$/.so/'`)
+.endif
+ @echo "Installing $(TK_STATIC_LIB_FILE)"
+ @$(INSTALL_DATA) $(TK_STATIC_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_STATIC_LIB_FILE)
+ @(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_STATIC_LIB_FILE))
+ @chmod 555 $(LIB_INSTALL_DIR)/$(TK_STATIC_LIB_FILE)
@echo "Installing wish@STEP@"
@$(INSTALL_PROGRAM) wish@STEP@ $(BIN_INSTALL_DIR)/wish@STEP@$(VERSION)
@echo "Installing tk@STEP@Config.sh"
- @$(INSTALL_DATA) tk@STEP@Config.sh $(LIB_INSTALL_DIR)/tk@STEP@Config.sh
+ @mkdir -p $(SCRIPT_INSTALL_DIR)
+ @$(INSTALL_DATA) tk@STEP@Config.sh $(SCRIPT_INSTALL_DIR)/tk@STEP@Config.sh
install-libraries:
@for i in $(INSTALL_ROOT)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
+ $(GENERIC_INCLUDE_INSTALL_DIR) $(UNIX_INCLUDE_INSTALL_DIR) \
$(SCRIPT_INSTALL_DIR) $(SCRIPT_INSTALL_DIR)/images; \
do \
if [ ! -d $$i ] ; then \
@@ -420,9 +444,19 @@
else true; \
fi; \
done;
- @echo "Installing tk@STEP@.h"
- @$(INSTALL_DATA) $(GENERIC_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk@STEP@.h
- for i in $(SRC_DIR)/library/*.tcl $(SRC_DIR)/library/*.xbm $(SRC_DIR)/library/tclIndex $(SRC_DIR)/library/prolog.ps $(UNIX_DIR)/tkAppInit.c; \
+ @echo "Installing headers"
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk@STEP@.h
+ for i in $(SRC_DIR)/library/*.tcl $(SRC_DIR)/library/tclIndex $(SRC_DIR)/library/prolog.ps $(UNIX_DIR)/tkAppInit.c; \
do \
echo "Installing $$i"; \
$(INSTALL_DATA) $$i $(SCRIPT_INSTALL_DIR); \
@@ -447,7 +481,7 @@
else true; \
fi; \
done;
- @for i in $(SRC_DIR)/library/demos/*; \
+ @for i in `echo $(SRC_DIR)/library/demos/* " "|sed 's/[^ ]*\.orig //g'`; \
do \
if [ -f $$i ] ; then \
echo "Installing $$i"; \
@@ -459,7 +493,7 @@
do \
chmod 755 $(SCRIPT_INSTALL_DIR)/demos/$$i; \
done;
- @for i in $(SRC_DIR)/library/demos/images/*; \
+ @for i in `echo $(SRC_DIR)/library/demos/images/* " "|sed 's/[^ ]*\.orig //g'`; \
do \
if [ -f $$i ] ; then \
echo "Installing $$i"; \
@@ -507,10 +541,10 @@
@cd $(SRC_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \
- rm -f $(MAN1_INSTALL_DIR)/$$i; \
+ rm -f $(MAN1_INSTALL_DIR)/$$i $(MAN1_INSTALL_DIR)/$$i.gz; \
sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
- $$i > $(MAN1_INSTALL_DIR)/$$i; \
- chmod 444 $(MAN1_INSTALL_DIR)/$$i; \
+ $$i | gzip -c > $(MAN1_INSTALL_DIR)/$$i.gz; \
+ chmod 444 $(MAN1_INSTALL_DIR)/$$i.gz; \
done;
$(UNIX_DIR)/mkLinks $(MAN1_INSTALL_DIR)
@cd $(SRC_DIR)/doc; for i in *.3; \
@@ -518,19 +552,26 @@
echo "Installing doc/$$i"; \
rm -f $(MAN3_INSTALL_DIR)/$$i; \
sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
- $$i > $(MAN3_INSTALL_DIR)/$$i; \
- chmod 444 $(MAN3_INSTALL_DIR)/$$i; \
+ $$i |gzip -c > $(MAN3_INSTALL_DIR)/$$i.gz; \
+ chmod 444 $(MAN3_INSTALL_DIR)/$$i.gz; \
done;
$(UNIX_DIR)/mkLinks $(MAN3_INSTALL_DIR)
@cd $(SRC_DIR)/doc; for i in *.n; \
do \
echo "Installing doc/$$i"; \
- rm -f $(MANN_INSTALL_DIR)/$$i; \
+ rm -f $(MANN_INSTALL_DIR)/$$i $(MANN_INSTALL_DIR)/$$i.gz; \
sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
- $$i > $(MANN_INSTALL_DIR)/$$i; \
- chmod 444 $(MANN_INSTALL_DIR)/$$i; \
+ $$i | gzip -c > $(MANN_INSTALL_DIR)/$$i.gz; \
+ chmod 444 $(MANN_INSTALL_DIR)/$$i.gz; \
done;
$(UNIX_DIR)/mkLinks $(MANN_INSTALL_DIR)
+ @echo "**********"
+ @echo "IMPORTANT:"
+ @echo "**********"
+ @echo "tkStepConfig.sh in $(SCRIPT_INSTALL_DIR)/tkStepConfig.sh"
+ @echo "tkstep.h in $(INCLUDE_INSTALL_DIR)/tkstep.h"
+ @echo "There are NOT default place, but good place to avoid"
+ @echo "conflicting with another version of Tcl/Tks."
Makefile: $(UNIX_DIR)/Makefile.in
$(SHELL) config.status