freebsd-ports/biology/sra-tools/files/patch-ncbi-vdb_build_Makefile.clang
Jason W. Bacon 69656bf0d7 biology/sra-tools: NCBI's toolkit for handling data in INSDC Sequence Read Archives
SRA tools is a toolkit for using data in the INSDC Sequence Read Archives.

SRAs operated by International Nucleotide Sequence Database Collaboration
houses sequence reads and alignments generated by "next-gen" sequencers.

This port is a bit convoluted due to the fact that the sra-tools build
requires access to the ncbi-vdb source tree.  Hence, ncbi-vdb is treated
as a submodule here rather than a separate library port.  We are working
with upstream with hope for long-term improvements.
2021-06-22 12:55:15 -05:00

30 lines
1.1 KiB
Text

--- ncbi-vdb/build/Makefile.clang.orig 2021-03-15 18:16:43 UTC
+++ ncbi-vdb/build/Makefile.clang
@@ -24,23 +24,23 @@
# compilers
-CC = @ $(TOP)/build/cc.sh $(OS) 'clang -c' \
+CC = @ $(TOP)/build/cc.sh $(OS) '$(CCNAME) -c' \
$(CHECKSUM) --objx $(OBJX) --cflags "$(CFLAGS)" -MD
-CP = @ $(TOP)/build/cc.sh $(OS) 'clang++ -c' \
+CP = @ $(TOP)/build/cc.sh $(OS) '$(CXXNAME) -c' \
$(CHECKSUM) --objx $(OBJX) -stdlib=libc++ --cflags "$(CPFLAGS)" -MD
# C preprocessor
PP = gcc -E $(CFLAGS)
# linkers
-LD = @ $(TOP)/build/ld.sh $(OS) $(ARCH) clang \
+LD = @ $(TOP)/build/ld.sh $(OS) $(ARCH) $(CCNAME) \
--build $(BUILD) --ldflags "$(LDFLAGS)" $(STATIC) \
$(STATICSYSLIBS) $(CHECKSUM) --objx $(OBJX) --shlx $(SHLX) --libx $(LIBX) \
-MD --srcdir $(SRCDIR) --bindir $(BINDIR) -L$(LIBDIR):$(ILIBDIR)
LPFLAGS = $(LDFLAGS)
-LP = @ $(TOP)/build/ld.sh $(OS) $(ARCH) clang++ \
+LP = @ $(TOP)/build/ld.sh $(OS) $(ARCH) $(CXXNAME) \
--build $(BUILD) --ldflags "$(LDFLAGS)" $(STATIC) \
$(STATICSYSLIBS) $(CHECKSUM) --objx $(OBJX) --shlx $(SHLX) --libx $(LIBX) \
-MD --srcdir $(SRCDIR) --bindir $(BINDIR) -L$(LIBDIR):$(ILIBDIR)