69656bf0d7
SRA tools is a toolkit for using data in the INSDC Sequence Read Archives. SRAs operated by International Nucleotide Sequence Database Collaboration houses sequence reads and alignments generated by "next-gen" sequencers. This port is a bit convoluted due to the fact that the sra-tools build requires access to the ncbi-vdb source tree. Hence, ncbi-vdb is treated as a submodule here rather than a separate library port. We are working with upstream with hope for long-term improvements.
11 lines
476 B
Text
11 lines
476 B
Text
--- tools/driver-tool/utf8proc/Makefile.orig 2021-04-29 14:50:48 UTC
|
|
+++ tools/driver-tool/utf8proc/Makefile
|
|
@@ -79,7 +79,7 @@ libutf8proc.a: utf8proc.o
|
|
|
|
libutf8proc.so.$(MAJOR).$(MINOR).$(PATCH): utf8proc.o
|
|
$(CC) $(LDFLAGS) -shared -o $@ -Wl,-soname -Wl,libutf8proc.so.$(MAJOR) utf8proc.o
|
|
- chmod a-x $@
|
|
+ # FIX .so build so this will work: chmod a-x $@
|
|
|
|
libutf8proc.so: libutf8proc.so.$(MAJOR).$(MINOR).$(PATCH)
|
|
ln -f -s libutf8proc.so.$(MAJOR).$(MINOR).$(PATCH) $@
|