freebsd-ports/lang/gcc/files/patch-al
1999-03-17 00:40:26 +00:00

47 lines
1.4 KiB
Text

--- gcc/configure.in.orig Sun Mar 7 16:22:22 1999
+++ gcc/configure.in Sat Mar 13 19:23:23 1999
@@ -416,6 +416,15 @@
thread_file='posix'
fi
;;
+ alpha*-*-freebsd*)
+ tm_file="${tm_file} freebsd.h alpha/freebsd.h alpha/freebsd-elf.h"
+ xm_file="${xm_file} xm-freebsd.h"
+ target_cpu_default="MASK_GAS"
+ tmake_file="t-freebsd alpha/t-crtbe"
+ xmake_file=none
+ fixincludes=fixinc.wrap
+ gas=yes gnu_ld=yes
+ ;;
alpha*-*-netbsd*)
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsdl-elf.h"
xm_file="xm-netbsd.h ${xm_file}"
@@ -872,21 +881,21 @@
# Next line turned off because both 386BSD and BSD/386 use GNU ld.
# use_collect2=yes
;;
- i[[34567]]86-*-freebsdelf*)
- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
+ i[[34567]]86-*-freebsdaout*)
+ tm_file=i386/freebsd-aout.h
# On FreeBSD, the headers are already ok, except for math.h.
fixincludes=fixinc.wrap
- extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
tmake_file=i386/t-freebsd
- gas=yes
- gnu_ld=yes
- stabs=yes
;;
i[[34567]]86-*-freebsd*)
- tm_file=i386/freebsd.h
+ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
# On FreeBSD, the headers are already ok, except for math.h.
fixincludes=fixinc.wrap
+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
tmake_file=i386/t-freebsd
+ gas=yes
+ gnu_ld=yes
+ stabs=yes
;;
i[[34567]]86-*-netbsd*)
tm_file=i386/netbsd.h