freebsd-ports/lang/spidermonkey/files/patch-config
OKAZAKI Tetsurou a4c5e709a7 Updates the port to Javascript 1.7.
Much thanks to Bernhard Fröhlich for doing the heavy lifting.

PR:		125191
Submitted by:	maintainer
2008-07-08 18:03:31 +00:00

43 lines
946 B
Text

--- config/Linux_All.mk 2005-05-10 21:53:44.000000000 +0200
+++ config/Linux_All.mk 2008-06-18 14:26:06.000000000 +0200
@@ -41,8 +41,8 @@
# Config for all versions of Linux
#
-CC = gcc
-CCC = g++
+CC ?= gcc
+CCC ?= g++
CFLAGS += -Wall -Wno-format
OS_CFLAGS = -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R
@@ -74,7 +74,7 @@
GFX_ARCH = x
-OS_LIBS = -lm -lc
+OS_LIBS = -lm
ASFLAGS += -x assembler-with-cpp
@@ -88,16 +88,12 @@
endif
# Use the editline library to provide line-editing support.
-JS_EDITLINE = 1
+JS_READLINE = 1
-ifeq ($(CPU_ARCH),x86_64)
-# Use VA_COPY() standard macro on x86-64
-# FIXME: better use it everywhere
OS_CFLAGS += -DHAVE_VA_COPY -DVA_COPY=va_copy
-endif
-ifeq ($(CPU_ARCH),x86_64)
-# We need PIC code for shared libraries
-# FIXME: better patch rules.mk & fdlibm/Makefile*
+ifeq ($(CPU_ARCH),sparc64)
OS_CFLAGS += -DPIC -fPIC
+else
+OS_CFLAGS += -DPIC -fpic
endif