runs as a single process, handling connections with select(2). For CGIs and directory listing it does fork(2). The minimum of HTTP/1.1 and CGI/1.1 are implemented. Also supported are: chroot, setuid, basic authentication, SSL, IPv6, custom responses, aliases, and virtual hosts. The access log is written in standard CLF format. AUTHOR: Glocker Marcus <marcus@nazgul.ch> WWW: http://www.nazgul.ch/dev_nostromo.html PR: ports/155919 Submitted by: Adrian Steinmann <ast@marabu.ch>
23 lines
376 B
Text
23 lines
376 B
Text
--- src/tools/Makefile.orig 2011-03-20 11:22:18.000000000 +0100
|
|
+++ src/tools/Makefile 2011-03-20 11:26:24.000000000 +0100
|
|
@@ -5,17 +5,18 @@
|
|
|
|
PIPE= -pipe
|
|
|
|
-NOMAN= 1
|
|
+NO_MAN= 1
|
|
|
|
BINOWN= root
|
|
BINMOD= 0555
|
|
-BINDIR= /usr/local/sbin
|
|
+BINDIR= ${PREFIX}/sbin
|
|
|
|
OS!= uname -s
|
|
|
|
.if ${OS} == "FreeBSD"
|
|
LDADD+= -lcrypt
|
|
.endif
|
|
+
|
|
.if ${OS} == "NetBSD"
|
|
LDADD+= -lcrypt
|
|
.endif
|