b6450d4ca7
- Update to 1.0.18 and pkg-plist accordingly - Add LICENSE (BSD3CLAUSE) and LICENSE_FILE - Add TEST_DEPENDS and regression-test target - Perl is not required, remove USE_PERL and from USES - Split LDFLAGS from CONFIGURE_ENV, they're already set there - Add libmemcachedprotocol to CONFIGURE_ARGS (Now default: off) - Add OPTIONS for hash functions, debug and dtrace - pkg-descr: Update WWW: URL - Add patches for: * alloca.h include not found on FreeBSD * cinttypes include location * clang compatibility - Strip shared libraries manually since upstream install-strip target is fail Changes: https://launchpad.net/libmemcached/+announcements [1] https://bugs.launchpad.net/libmemcached/+bug/1245562 [2] https://bugs.launchpad.net/libmemcached/+bug/1400560 Approved by: Mikhail Tsatsenko <m.tsatsenko@gmail.com> (maintainer, via email)
13 lines
257 B
C++
13 lines
257 B
C++
--- libmemcached/assert.hpp.orig 2014-12-10 05:16:11 UTC
|
|
+++ libmemcached/assert.hpp
|
|
@@ -51,8 +51,10 @@
|
|
# ifdef _WIN32
|
|
# include <malloc.h>
|
|
# else
|
|
+#ifdef HAVE_ALLOCA_H
|
|
# include <alloca.h>
|
|
# endif
|
|
+# endif
|
|
|
|
#ifdef __cplusplus
|
|
# include <cstdarg>
|