freebsd-ports/devel/ice37/files/patch-python-python-Makefile
Michael Gmelin 0c2e1ae609 Add ZeroC Ice 3.7.1 as new ports devel/{ice37|php-ice37|py-ice37}
Upgrading from Ice 3.6 isn't trivial, as it requires application
code changes. Therefore a new set of ports was created.

Marked devel/{ice|php5-ice|py-ice} as conflicting (and vice versa).

PR:		221141
2018-08-27 16:37:53 +00:00

28 lines
1.3 KiB
Text

--- python/python/Makefile.orig 2018-04-20 15:02:08 UTC
+++ python/python/Makefile
@@ -16,7 +16,7 @@ include $(lang_srcdir)/config/Make.rules
#
# Load C++ dependencies
#
-$(eval $(call load-translator-dependencies,$(top_srcdir)/cpp/src/slice2py))
+#$(eval $(call load-translator-dependencies,$(top_srcdir)/cpp/src/slice2py))
.NOTPARALLEL:
@@ -35,12 +35,12 @@ $(eval $(call make-python-slice,$(sliced
install:: | $(DESTDIR)$(install_pythondir)/Ice
$(E) "Installing generated code"
- $(Q)$(INSTALL) -m 644 Ice/__init__.py $(DESTDIR)$(install_pythondir)/Ice
+ $(Q)%%INSTALL_DATA%% -m 644 Ice/__init__.py $(DESTDIR)$(install_pythondir)/Ice
# Ice/Future requires python >= 3.5
ifeq ($(shell $(PYTHON) -c "print(1 if $(python-version) >= 3.5 else 0)"),1)
- $(Q)$(INSTALL) -d -m 755 $(DESTDIR)$(install_pythondir)/Ice/Py3
- $(Q)$(INSTALL) -m 644 Ice/Py3/IceFuture.py $(DESTDIR)$(install_pythondir)/Ice/Py3/
+ $(Q)%%MKDIR%% $(DESTDIR)$(install_pythondir)/Ice/Py3
+ $(Q)%%INSTALL_DATA%% -m 644 Ice/Py3/IceFuture.py $(DESTDIR)$(install_pythondir)/Ice/Py3/
endif
install:: | $(DESTDIR)$(install_pythondir)/Glacier2
- $(Q)$(INSTALL) -m 644 Glacier2/__init__.py $(DESTDIR)$(install_pythondir)/Glacier2
+ $(Q)%%INSTALL_DATA%% -m 644 Glacier2/__init__.py $(DESTDIR)$(install_pythondir)/Glacier2