b7fded5275
agglomerative clustering. Its features include * generating hierarchical clusters from distance matrices * computing distance matrices from observation vectors * computing statistics on clusters * cutting linkages to generate flat clusters * and visualizing clusters with dendrograms. The interface is very similar to MATLAB's Statistics Toolbox API to make code easier to port from MATLAB to Python/Numpy. The core implementation of this library is in C for efficiency. WWW: http://code.google.com/p/scipy-cluster/ PR: ports/127515 Submitted by: Wen Heping <wenheping at gmail.com>
12 lines
414 B
Python
12 lines
414 B
Python
--- setup.py.orig 2008-09-21 22:20:16.000000000 +0800
|
|
+++ setup.py 2008-09-21 22:20:34.000000000 +0800
|
|
@@ -33,7 +33,8 @@
|
|
print string.join(l, '\n')
|
|
# Prompt the user with a list of selections.
|
|
while not (s >= 1 and s <= len(valid_paths)):
|
|
- s = input('Selection [default=1]:' % s)
|
|
+# s = input('Selection [default=1]:' % s)
|
|
+ s=1
|
|
if s == '':
|
|
s = 1
|
|
else:
|