486518fcaa
threaded in order to better deal with the requirements of multi-interface routers. Information regarding MAC addresses and interfaces is maintained by the program, and an alert is issued should a device move between interfaces. In addition, event processing has been refactored, and some bugs have been fixed. PR: 59180 Submitted by: Matthew George <mdg@secureworks.net> Approved by: portmgr
22 lines
811 B
Text
22 lines
811 B
Text
--- ../arpwatch.orig/Makefile.in Wed Jun 14 20:39:55 2000
|
|
+++ ./Makefile.in Mon Sep 15 14:31:33 2003
|
|
@@ -45,7 +45,7 @@
|
|
PROG = arpwatch
|
|
CCOPT = @V_CCOPT@
|
|
INCLS = -I. @V_INCLS@
|
|
-DEFS = -DDEBUG @DEFS@ -DARPDIR=\"$(ARPDIR)\" -DPATH_SENDMAIL=\"$(SENDMAIL)\"
|
|
+DEFS = @DEFS@ -pthread -DARPDIR=\"$(ARPDIR)\" -DPATH_SENDMAIL=\"$(SENDMAIL)\"
|
|
|
|
# Standard CFLAGS
|
|
CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
|
|
@@ -110,8 +110,8 @@
|
|
$(CC) $(CFLAGS) -o $@ zap.o intoa.o -lutil
|
|
|
|
install: force
|
|
- $(INSTALL) -m 555 -o bin -g bin arpwatch $(DESTDIR)$(BINDEST)
|
|
- $(INSTALL) -m 555 -o bin -g bin arpsnmp $(DESTDIR)$(BINDEST)
|
|
+ $(INSTALL) -s -m 555 -o bin -g bin arpwatch $(DESTDIR)$(BINDEST)
|
|
+ $(INSTALL) -s -m 555 -o bin -g bin arpsnmp $(DESTDIR)$(BINDEST)
|
|
|
|
install-man: force
|
|
$(INSTALL) -m 444 -o bin -g bin $(srcdir)/arpwatch.8 \
|