* Add needed x11 and xext dependencies Thanks to everyone who submitted patches, tested, and reviewed this update. PR: 201340 Submitted by: Bengt Ahlgren <bengta at sics.se>, Kevin Bowling <kbowling@>, Oleg <zoleg at vusovich.ru>, Tomoaki AOKI <junchoon at dec.sakura.ne.jp>, Ultima <Ultima1252 at gmail.com> Tested by: Jeremy Cox <jeremy.m.cox at gmail.com>, O. Hartmann <ohartman at zedat.fu-berlin.de>, Tomoaki AOKI Approved by: danfe Differential Revision: https://reviews.freebsd.org/D7569
18 lines
457 B
Text
18 lines
457 B
Text
--- src/nvidia/Makefile.orig 2014-04-04 23:24:59.000000000 +0200
|
|
+++ src/nvidia/Makefile 2014-05-06 14:31:07.000000000 +0200
|
|
@@ -24,6 +24,15 @@
|
|
stdarg.h:
|
|
@ln -s machine/stdarg.h stdarg.h
|
|
|
|
+SRCS+= opt_global.h
|
|
+.if ${MACHINE_ARCH} == "i386" && !defined(KERNBUILDDIR)
|
|
+PAE!= sed -n '/define NV_SUPPORT_PAE/p' nv-freebsd.h
|
|
+.if !empty(PAE)
|
|
+opt_global.h:
|
|
+ echo "#define PAE 1" > ${.TARGET}
|
|
+.endif
|
|
+.endif
|
|
+
|
|
*.c: stdarg.h
|
|
|
|
beforeinstall: ${KMOD}.ko
|