freebsd-ports/www/xulrunner/files/patch-libm
Michael Johnson 52c4662281 - Add xulrunner
Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications
that are as rich as Firefox and Thunderbird. It will provide mechanisms for
installing, upgrading, and uninstalling these applications. XULRunner will
also provide libxul, a solution which allows the embedding of Mozilla
technologies in other projects and products.

WWW: http://developer.mozilla.org/en/docs/XULRunner

Most patches obtained from:	www/seamonkey
2006-03-15 11:35:32 +00:00

25 lines
572 B
Text

--- js/src/Makefile.in Thu Aug 4 22:26:52 2005
+++ js/src/Makefile.in Thu Aug 4 23:02:32 2005
@@ -148,5 +148,4 @@
endif
-FDLIBM_LIBRARY = fdlibm/$(LIB_PREFIX)fdm.$(LIB_SUFFIX)
JSMATH_PRELINK = jsmathtemp.o
JS_SAFE_ARENA = 1
@@ -320,7 +319,4 @@
endif
@$(RM) -f $(JSMATH_PRELINK)
-else
-# Create dependency so we build fdlibm
-jsmath.o: $(FDLIBM_LIBRARY) Makefile.in
endif
--- js/Makefile.in Sun Mar 23 14:36:00 2003
+++ js/Makefile.in Thu Aug 4 23:08:06 2005
@@ -46,5 +46,5 @@
#
-DIRS = src/fdlibm src
+DIRS = src
include $(topsrcdir)/config/rules.mk