52c4662281
Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications that are as rich as Firefox and Thunderbird. It will provide mechanisms for installing, upgrading, and uninstalling these applications. XULRunner will also provide libxul, a solution which allows the embedding of Mozilla technologies in other projects and products. WWW: http://developer.mozilla.org/en/docs/XULRunner Most patches obtained from: www/seamonkey
156 lines
5.2 KiB
Text
156 lines
5.2 KiB
Text
--- Makefile.in Tue Sep 14 16:59:40 2004
|
|
+++ Makefile.in Tue Aug 2 08:26:55 2005
|
|
@@ -102,6 +102,4 @@
|
|
# tier 1 - 3rd party individual libraries
|
|
#
|
|
-tier_1_dirs += dbm
|
|
-
|
|
ifndef MOZ_NATIVE_JPEG
|
|
tier_1_dirs += jpeg
|
|
--- security/manager/ssl/src/Makefile.in Wed Jan 7 08:36:51 2004
|
|
+++ security/manager/ssl/src/Makefile.in Tue Aug 2 09:13:07 2005
|
|
@@ -117,5 +117,5 @@
|
|
# Use local includes because they are inserted before INCLUDES
|
|
# so that Mozilla's nss.h is used, not glibc's
|
|
-LOCAL_INCLUDES += -I$(DIST)/public/nss \
|
|
+LOCAL_INCLUDES += -I$(LOCALBASE)/include/nss/nss \
|
|
$(NULL)
|
|
|
|
--- config/config.mk Tue Oct 12 00:11:11 2004
|
|
+++ config/config.mk Tue Aug 2 09:19:18 2005
|
|
@@ -170,5 +170,4 @@
|
|
NSS_LIBS = \
|
|
$(LIBS_DIR) \
|
|
- $(DIST)/lib/$(LIB_PREFIX)crmf.$(LIB_SUFFIX) \
|
|
-lsmime3 \
|
|
-lssl3 \
|
|
@@ -189,11 +188,5 @@
|
|
endif
|
|
|
|
-NSS_DEP_LIBS = \
|
|
- $(DIST)/lib/$(LIB_PREFIX)crmf.$(LIB_SUFFIX) \
|
|
- $(DIST)/lib/$(DLL_PREFIX)smime3$(DLL_SUFFIX) \
|
|
- $(DIST)/lib/$(DLL_PREFIX)ssl3$(DLL_SUFFIX) \
|
|
- $(DIST)/lib/$(DLL_PREFIX)nss3$(DLL_SUFFIX) \
|
|
- $(DIST)/lib/$(DLL_PREFIX)softokn3$(DLL_SUFFIX) \
|
|
- $(NULL)
|
|
+NSS_DEP_LIBS =
|
|
|
|
MOZ_UNICHARUTIL_LIBS = $(DIST)/lib/$(LIB_PREFIX)unicharutil_s.$(LIB_SUFFIX)
|
|
--- security/manager/ssl/src/nsNSSComponent.cpp Thu Apr 22 15:48:30 2004
|
|
+++ security/manager/ssl/src/nsNSSComponent.cpp Thu Aug 4 16:44:27 2005
|
|
@@ -88,4 +88,8 @@
|
|
}
|
|
|
|
+#include <sys/types.h>
|
|
+#include <sys/stat.h>
|
|
+#include <errno.h>
|
|
+
|
|
#ifdef PR_LOGGING
|
|
PRLogModuleInfo* gPIPNSSLog = nsnull;
|
|
@@ -406,4 +410,5 @@
|
|
const char *possible_ckbi_locations[] = {
|
|
NS_GRE_DIR,
|
|
+ NS_UNIX_LIB_DIR,
|
|
NS_XPCOM_CURRENT_PROCESS_DIR
|
|
};
|
|
@@ -419,5 +424,5 @@
|
|
}
|
|
|
|
- char *fullModuleName = nsnull;
|
|
+ char *fullModuleName;
|
|
#ifdef XP_MAC
|
|
nsCAutoString nativePath;
|
|
@@ -431,4 +436,12 @@
|
|
fullModuleName = PR_GetLibraryName(processDir.get(), "nssckbi");
|
|
#endif
|
|
+ if (fullModuleName == nsnull)
|
|
+ continue;
|
|
+ struct stat sb;
|
|
+ if (stat(fullModuleName, &sb)) {
|
|
+ if (errno != ENOENT)
|
|
+ perror(fullModuleName);
|
|
+ continue;
|
|
+ }
|
|
/* If a module exists with the same name, delete it. */
|
|
NS_ConvertUCS2toUTF8 modNameUTF8(modName);
|
|
--- security/manager/Makefile.in.orig Wed Nov 2 16:50:36 2005
|
|
+++ security/manager/Makefile.in Fri Nov 11 02:14:27 2005
|
|
@@ -52,18 +52,9 @@
|
|
SSL3_LIB \
|
|
SOFTOKEN3_LIB \
|
|
SOFTOKEN3_CHK \
|
|
- LOADABLE_ROOT_MODULE \
|
|
HAVE_FREEBL_MODULES \
|
|
$(NULL)
|
|
|
|
-LOADABLE_ROOT_MODULE = $(DLL_PREFIX)nssckbi$(DLL_SUFFIX)
|
|
-
|
|
-NSS3_LIB = $(DLL_PREFIX)nss3$(DLL_SUFFIX)
|
|
-SMIME3_LIB = $(DLL_PREFIX)smime3$(DLL_SUFFIX)
|
|
-SSL3_LIB = $(DLL_PREFIX)ssl3$(DLL_SUFFIX)
|
|
-SOFTOKEN3_LIB = $(DLL_PREFIX)softokn3$(DLL_SUFFIX)
|
|
-SOFTOKEN3_CHK = $(DLL_PREFIX)softokn3.chk
|
|
-
|
|
ifneq (,$(filter SunOS HP-UX,$(OS_ARCH)))
|
|
ifeq (,$(filter i86pc ia64,$(OS_TEST)))
|
|
ifndef HAVE_64BIT_OS
|
|
@@ -151,11 +142,6 @@
|
|
|
|
.nss.cleaned: .nss.checkout
|
|
$(MAKE) -C $(topsrcdir)/security/coreconf $(DEFAULT_GMAKE_FLAGS) clean
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/lib $(DEFAULT_GMAKE_FLAGS) clean
|
|
-ifndef SKIP_CHK
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/cmd/lib $(DEFAULT_GMAKE_FLAGS) clean
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/cmd/shlibsign $(DEFAULT_GMAKE_FLAGS) clean
|
|
-endif
|
|
touch $@
|
|
|
|
.nss.checkout:
|
|
@@ -176,10 +162,10 @@
|
|
else
|
|
cd $(DIST)/lib; cp -f $(LIB_PREFIX)mozdbm_s.$(LIB_SUFFIX) $(LIB_PREFIX)dbm.$(LIB_SUFFIX); $(RANLIB) $(LIB_PREFIX)dbm.$(LIB_SUFFIX)
|
|
endif
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/lib $(DEFAULT_GMAKE_FLAGS)
|
|
+# $(MAKE) -C $(topsrcdir)/security/nss/lib $(DEFAULT_GMAKE_FLAGS)
|
|
ifndef SKIP_CHK
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/cmd/lib $(DEFAULT_GMAKE_FLAGS)
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/cmd/shlibsign $(DEFAULT_GMAKE_FLAGS)
|
|
+# $(MAKE) -C $(topsrcdir)/security/nss/cmd/lib $(DEFAULT_GMAKE_FLAGS)
|
|
+# $(MAKE) -C $(topsrcdir)/security/nss/cmd/shlibsign $(DEFAULT_GMAKE_FLAGS)
|
|
endif
|
|
$(INSTALL) -m 755 $(DIST)/lib/$(LOADABLE_ROOT_MODULE) $(DIST)/bin
|
|
ifndef SKIP_CHK
|
|
@@ -203,20 +189,6 @@
|
|
endif
|
|
|
|
install::
|
|
- $(SYSINSTALL) -m 755 $(DIST)/lib/$(LOADABLE_ROOT_MODULE) $(DESTDIR)$(mozappdir)
|
|
-ifndef SKIP_CHK
|
|
- $(SYSINSTALL) -m 644 $(DIST)/lib/$(SOFTOKEN3_CHK) $(DESTDIR)$(mozappdir)
|
|
-endif
|
|
- $(SYSINSTALL) -m 755 $(DIST)/lib/$(SOFTOKEN3_LIB) $(DESTDIR)$(mozappdir)
|
|
- $(SYSINSTALL) -m 755 $(DIST)/lib/$(NSS3_LIB) $(DESTDIR)$(mozappdir)
|
|
- $(SYSINSTALL) -m 755 $(DIST)/lib/$(SSL3_LIB) $(DESTDIR)$(mozappdir)
|
|
- $(SYSINSTALL) -m 755 $(DIST)/lib/$(SMIME3_LIB) $(DESTDIR)$(mozappdir)
|
|
-ifdef HAVE_FREEBL_MODULES
|
|
- $(SYSINSTALL) -m 644 $(DIST)/lib/$(FREEBL_PURE32_CHK) $(DESTDIR)$(mozappdir)
|
|
- $(SYSINSTALL) -m 755 $(DIST)/lib/$(FREEBL_PURE32_MODULE) $(DESTDIR)$(mozappdir)
|
|
- $(SYSINSTALL) -m 644 $(DIST)/lib/$(FREEBL_HYBRID_CHK) $(DESTDIR)$(mozappdir)
|
|
- $(SYSINSTALL) -m 755 $(DIST)/lib/$(FREEBL_HYBRID_MODULE) $(DESTDIR)$(mozappdir)
|
|
-endif
|
|
$(MAKE) -C boot $@
|
|
$(MAKE) -C ssl $@
|
|
$(MAKE) -C locales $@
|
|
@@ -232,11 +204,6 @@
|
|
$(MAKE) -C pki $@
|
|
endif
|
|
$(MAKE) -C $(topsrcdir)/security/coreconf $(DEFAULT_GMAKE_FLAGS) clean
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/lib $(DEFAULT_GMAKE_FLAGS) clean
|
|
-ifndef SKIP_CHK
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/cmd/lib $(DEFAULT_GMAKE_FLAGS) clean
|
|
- $(MAKE) -C $(topsrcdir)/security/nss/cmd/shlibsign $(DEFAULT_GMAKE_FLAGS) clean
|
|
-endif
|
|
|
|
echo-requires-recursive::
|
|
$(MAKE) -C boot $@
|