826dbb8ea7
Rescale. The API is intended to be powerful, yet fast and easy to use. It supports saving and loading of the carving information, real-time scaling, manual feature selection, customizable progress report and more. WWW: http://liblqr.wikidot.com/ PR: ports/120237 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
33 lines
820 B
Text
33 lines
820 B
Text
--- examples/Makefile.orig 2007-12-21 18:02:50.000000000 +0300
|
|
+++ examples/Makefile 2008-01-30 05:43:08.000000000 +0300
|
|
@@ -23,6 +23,8 @@
|
|
|
|
|
|
# collect flags for the compiler for lqr library
|
|
+CXX ?= g++
|
|
+
|
|
LQR_CFLAGS = `pkg-config --cflags lqr-1`
|
|
|
|
LQR_LIBS = `pkg-config --libs lqr-1`
|
|
@@ -59,17 +61,17 @@
|
|
|
|
# linking
|
|
$(tt1out) : $(tt1obj)
|
|
- g++ $(LINKING_FLAGS) -o $(tt1out) $(tt1obj)
|
|
+ $(CXX) $(tt1obj) $(LINKING_FLAGS) -o $(tt1out)
|
|
|
|
$(tt2out) : $(tt2obj)
|
|
- g++ $(LINKING_FLAGS) -o $(tt2out) $(tt2obj)
|
|
+ $(CXX) $(tt2obj) $(LINKING_FLAGS) -o $(tt2out)
|
|
|
|
# object building
|
|
$(tt1).o : $(tt1).cpp $(tt1).h
|
|
- g++ -c $(OBJ_BUILD_FLAGS) $(tt1).cpp
|
|
+ $(CXX) -c $(OBJ_BUILD_FLAGS) $(tt1).cpp
|
|
|
|
$(tt2).o : $(tt2).cpp
|
|
- g++ -c $(OBJ_BUILD_FLAGS) $(tt2).cpp
|
|
+ $(CXX) -c $(OBJ_BUILD_FLAGS) $(tt2).cpp
|
|
|
|
#cleanup
|
|
clean:
|