46 lines
1.9 KiB
Text
46 lines
1.9 KiB
Text
--- CMakeLists.txt.orig 2010-07-20 01:38:35.000000000 +0400
|
|
+++ CMakeLists.txt 2010-07-30 16:21:01.000000000 +0400
|
|
@@ -92,7 +92,6 @@
|
|
# Did we find wxWidgets ? This condition will fail for as long as the internal Vars do not point to the proper wxWidgets Configuration.
|
|
IF(wxWidgets_FOUND)
|
|
# Include wxWidgets macros
|
|
- INCLUDE(${wxWidgets_USE_FILE})
|
|
IF(MSVC)
|
|
INCLUDE_DIRECTORIES( ${wxWidgets_ROOT_DIR}/include/msvc )
|
|
ENDIF(MSVC)
|
|
@@ -100,6 +99,9 @@
|
|
SET(wxWidgets_RC_DIR ${wxWidgets_ROOT_DIR}/include)
|
|
ENDIF(MINGW)
|
|
INCLUDE_DIRECTORIES( ${wxWidgets_INCLUDE_DIRS} )
|
|
+ STRING(REGEX REPLACE ";" ";-D" wxWidgets_DEFINITIONS "${wxWidgets_DEFINITIONS}")
|
|
+ SET(wxWidgets_DEFINITIONS "-D${wxWidgets_DEFINITIONS}")
|
|
+ ADD_DEFINITIONS( ${wxWidgets_DEFINITIONS} )
|
|
ELSE(wxWidgets_FOUND)
|
|
# For Convenience. If we cannot continue, inform the User.
|
|
MESSAGE( FATAL_ERROR "wxWidgets library not found! Please install the package to continue")
|
|
@@ -120,7 +122,7 @@
|
|
|
|
Add_Subdirectory( ${springlobby_SOURCE_DIR}/src/sound/alure )
|
|
INCLUDE_DIRECTORIES( ${springlobby_SOURCE_DIR}/src/sound/alure/include )
|
|
- LINK_LIBRARIES( ${OPENAL_LIBRARY} ${springlobby_BINARY_DIR}/src/sound/alure/libalure.a )
|
|
+ LINK_LIBRARIES( ${OPENAL_LIBRARY} alure )
|
|
ELSE ( OPTION_SOUND )
|
|
# Disable sound.
|
|
ADD_DEFINITIONS( -DDISABLE_SOUND )
|
|
@@ -171,7 +173,7 @@
|
|
IF( Boost_FOUND )
|
|
link_directories( ${Boost_LIB_DIR} )
|
|
INCLUDE_DIRECTORIES( ${Boost_INCLUDE_DIR} )
|
|
- SET( SL_BOOST_LIBS boost_system-mt )
|
|
+ SET( SL_BOOST_LIBS boost_system )
|
|
ELSE()
|
|
MESSAGE( FATAL_ERROR "boost library not found! Please install the package or toggle OPTION_TORRENT_SYSTEM to OFF")
|
|
ENDIF()
|
|
@@ -185,6 +187,7 @@
|
|
LIST( APPEND SLSharedWithSettings ${curlSRC} )
|
|
ELSE( OPTION_TORRENT_SYSTEM )
|
|
ADD_DEFINITIONS( -DNO_TORRENT_SYSTEM )
|
|
+ LIST( APPEND SLSharedWithSettings ${curlSRC} )
|
|
ENDIF( OPTION_TORRENT_SYSTEM )
|
|
|
|
|