freebsd-ports/net/ntop/files/patch-configure.in
Matthias Andree c1ce3029fd Fix build on 8.x, by leveraging USE_BINUTILS=yes there (before 900033).
The older binutils are picky and error out when trying to strip .a
files, the newer binutils just skip over things and print warnings. [1]

Fix build with WITH_SSP[_PORTS]=yes, by not running together LDFLAGS
expansions; this drops one hunk from files/patch-configure.in.

Modernize USE_PYTHON and @unexec rmdir.

PR:		192047 [1]
Submitted by:	feld@ [1], Janos Dohanics [1, to ports@]
2014-09-05 22:05:35 +00:00

47 lines
1.7 KiB
Text

--- configure.in.orig 2012-08-13 04:35:26.000000000 -0300
+++ configure.in 2013-01-09 13:11:12.000000000 -0200
@@ -560,7 +560,7 @@
test -d ${TMP_ROOT} &&
test -r ${TMP_ROOT}/libpcap.a; then
PCAP_ROOT=${TMP_ROOT}
- CORELIBS="${CORELIBS} -L${TMP_ROOT} -L${HOME}/PF_RING/userland/lib -lpfring -lpcap "
+ CORELIBS="${CORELIBS}-L${TMP_ROOT}-L${HOME}/PF_RING/userland/lib -lpfring -lpcap "
INCS="${INCS} -I ${PCAP_ROOT}"
AC_MSG_RESULT([found in $PCAP_ROOT])
elif test ".${PCAP_ROOT}" != .; then
@@ -568,7 +568,7 @@
test -r $PCAP_ROOT/lib/libpcap.a &&
test -r $PCAP_ROOT/include/pcap.h; then
PCAP_ROOT=`cd ${PCAP_ROOT} && pwd`
- CORELIBS="${CORELIBS} -L ${PCAP_ROOT}/lib -lpcap"
+ CORELIBS="${CORELIBS}-L${PCAP_ROOT}/lib -lpcap"
INCS="${INCS} -I ${PCAP_ROOT}/include"
AC_MSG_RESULT([found in $PCAP_ROOT])
else
@@ -584,7 +584,7 @@
test -r /usr/local/lib/libpcap.a &&
test -r /usr/local/include/pcap.h; then
PCAP_ROOT="/usr/local"
- CORELIBS="${CORELIBS} -L$PCAP_ROOT/lib -lpcap"
+ CORELIBS="${CORELIBS}-L$PCAP_ROOT/lib -lpcap"
INCS="${INCS} -I$PCAP_ROOT/include"
AC_MSG_RESULT([found in $PCAP_ROOT])
dnl>
@@ -1744,8 +1744,6 @@
else
if test -f "3rd_party/GeoLiteCity.dat.gz"; then
cp 3rd_party/GeoLiteCity.dat.gz .
- else
- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
fi
gunzip GeoLiteCity.dat.gz
@@ -1758,8 +1756,6 @@
else
if test -f "3rd_party/GeoIPASNum.dat.gz"; then
cp 3rd_party/GeoIPASNum.dat.gz .
- else
- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
fi
gunzip GeoIPASNum.dat.gz