5c9a928450
- Provide an option to build a statically linked version
11 lines
326 B
Text
11 lines
326 B
Text
--- CMakeLists.txt.orig 2018-02-18 21:31:50 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -8,6 +8,8 @@ option(WITH_HTTPD "HTTP REST API" ON)
|
|
include (CheckIncludeFile)
|
|
include (cmake/cpu.cmake)
|
|
|
|
+set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -static")
|
|
+set(CMAKE_FIND_LIBRARY_SUFFIXES ".a")
|
|
|
|
set(HEADERS
|
|
src/3rdparty/align.h
|