freebsd-ports/devel/allegro-devel/files/patch-CMakeLists.txt
Ruslan Makhmatkhanov 55c99b07ef - apply patches for files/, that I forgot in previous commit, to fix build
Reported by:	beatmail (pointyhat)
2012-09-21 07:09:29 +00:00

20 lines
608 B
Text

--- CMakeLists.txt.orig
+++ CMakeLists.txt
@@ -66,7 +66,7 @@
endif(WIN32)
set(ALLEGRO_VERSION 4.4.2)
-string(REGEX MATCH "^[0-9]+[.][0-9]+" ALLEGRO_SOVERSION ${ALLEGRO_VERSION})
+string(REGEX MATCH "^[0-9]" ALLEGRO_SOVERSION ${ALLEGRO_VERSION})
# Mac OS X -compatibility_version.
# XXX doesn't seem to work
@@ -961,7 +961,7 @@
@ONLY
)
install(FILES ${LIBRARY_OUTPUT_PATH}/pkgconfig/${name}${lib_type}.pc
- DESTINATION "lib${LIB_SUFFIX}/pkgconfig"
+ DESTINATION "libdata/pkgconfig"
)
endforeach(name)
endif(UNIX)