9b586f478b
- Add WITH_ESOUND knob and enable the plugin build - Fix bsdvideo (bktr(4)) plugin and make it buildable on more archs - Add a small error handler to detect unresolved symbols in plugins - Add more plugins to pkg-plist - Add experimental support for firewire(4) based video devices. The segment of the Makefile is intentionally commented out. PR: ports/95422, ports/96624 Submitted by: Joerg Pulz <Joerg.Pulz@frm2.tum.de>, Steve Ames <steve@energistic.com> (maintainer) Approved by: Steve Ames <steve@energistic.com> (maintainer)
347 lines
13 KiB
Text
347 lines
13 KiB
Text
--- plugins/configure.orig Thu Apr 6 10:16:09 2006
|
|
+++ plugins/configure Thu Apr 6 09:56:04 2006
|
|
@@ -309,7 +309,7 @@
|
|
# include <unistd.h>
|
|
#endif"
|
|
|
|
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_OSS HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
|
|
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS CXX CXXFLAGS LDFLAGS CPPFLAGS ac_ct_CXX EXEEXT OBJEXT PWLIBDIR PWINSTDIR INSTALLPREFIX LIBDIR CC CFLAGS ac_ct_CC CPP EGREP HAS_ALSA HAS_OSS HAS_ESD HAS_SUNAUDIO HAS_V4L HAS_V4L2 HAS_BSDVIDEOCAP HAS_AVC1394 HAS_DC1394 DC_CFLAGS LIBOBJS LTLIBOBJS'
|
|
ac_subst_files=''
|
|
|
|
# Initialize some variables set by options.
|
|
@@ -852,6 +852,7 @@
|
|
--disable-audio disable audio support
|
|
--enable-alsa enable ALSA audio support
|
|
--enable-oss enable OSS audio support
|
|
+ --enable-esd enable ESD audio support
|
|
--enable-sunaudio enable Sun audio support
|
|
--disable-video disable video device support in PWLIB
|
|
--enable-v4l enable V4L video support
|
|
@@ -3444,6 +3459,172 @@
|
|
fi
|
|
|
|
|
|
+# Check whether --enable-esd or --disable-esd was given.
|
|
+if test "${enable_esd+set}" = set; then
|
|
+ enableval="$enable_esd"
|
|
+
|
|
+else
|
|
+ enable_oss=yes
|
|
+fi;
|
|
+
|
|
+if test "${enable_esd}z" = "yesz" ; then
|
|
+ if test "${ac_cv_header_esd_h+set}" = set; then
|
|
+ echo "$as_me:$LINENO: checking for esd.h" >&5
|
|
+echo $ECHO_N "checking for esd.h... $ECHO_C" >&6
|
|
+if test "${ac_cv_header_esd_h+set}" = set; then
|
|
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
+fi
|
|
+echo "$as_me:$LINENO: result: $ac_cv_header_esd_h" >&5
|
|
+echo "${ECHO_T}$ac_cv_header_esd_h" >&6
|
|
+else
|
|
+ # Is the header compilable?
|
|
+echo "$as_me:$LINENO: checking esd.h usability" >&5
|
|
+echo $ECHO_N "checking esd.h usability... $ECHO_C" >&6
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+$ac_includes_default
|
|
+#include <esd.h>
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ ac_header_compiler=yes
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ac_header_compiler=no
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
|
|
+echo "${ECHO_T}$ac_header_compiler" >&6
|
|
+
|
|
+# Is the header present?
|
|
+echo "$as_me:$LINENO: checking esd.h presence" >&5
|
|
+echo $ECHO_N "checking esd.h presence... $ECHO_C" >&6
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#include <esd.h>
|
|
+_ACEOF
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
|
|
+ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } >/dev/null; then
|
|
+ if test -s conftest.err; then
|
|
+ ac_cpp_err=$ac_c_preproc_warn_flag
|
|
+ ac_cpp_err=$ac_cpp_err$ac_c_werror_flag
|
|
+ else
|
|
+ ac_cpp_err=
|
|
+ fi
|
|
+else
|
|
+ ac_cpp_err=yes
|
|
+fi
|
|
+if test -z "$ac_cpp_err"; then
|
|
+ ac_header_preproc=yes
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ ac_header_preproc=no
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_ext
|
|
+echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
|
|
+echo "${ECHO_T}$ac_header_preproc" >&6
|
|
+
|
|
+# So? What about this header?
|
|
+case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
|
|
+ yes:no: )
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: accepted by the compiler, rejected by the preprocessor!" >&5
|
|
+echo "$as_me: WARNING: esd.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: proceeding with the compiler's result" >&5
|
|
+echo "$as_me: WARNING: esd.h: proceeding with the compiler's result" >&2;}
|
|
+ ac_header_preproc=yes
|
|
+ ;;
|
|
+ no:yes:* )
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: present but cannot be compiled" >&5
|
|
+echo "$as_me: WARNING: esd.h: present but cannot be compiled" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: check for missing prerequisite headers?" >&5
|
|
+echo "$as_me: WARNING: esd.h: check for missing prerequisite headers?" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: see the Autoconf documentation" >&5
|
|
+echo "$as_me: WARNING: esd.h: see the Autoconf documentation" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: section \"Present But Cannot Be Compiled\"" >&5
|
|
+echo "$as_me: WARNING: esd.h: section \"Present But Cannot Be Compiled\"" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: proceeding with the preprocessor's result" >&5
|
|
+echo "$as_me: WARNING: esd.h: proceeding with the preprocessor's result" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: esd.h: in the future, the compiler will take precedence" >&5
|
|
+echo "$as_me: WARNING: esd.h: in the future, the compiler will take precedence" >&2;}
|
|
+ (
|
|
+ cat <<\_ASBOX
|
|
+## ------------------------------------------ ##
|
|
+## Report this to the AC_PACKAGE_NAME lists. ##
|
|
+## ------------------------------------------ ##
|
|
+_ASBOX
|
|
+ ) |
|
|
+ sed "s/^/$as_me: WARNING: /" >&2
|
|
+ ;;
|
|
+esac
|
|
+echo "$as_me:$LINENO: checking for esd.h" >&5
|
|
+echo $ECHO_N "checking for esd.h... $ECHO_C" >&6
|
|
+if test "${ac_cv_header_esd_h+set}" = set; then
|
|
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
+else
|
|
+ ac_cv_header_esd_h=$ac_header_preproc
|
|
+fi
|
|
+echo "$as_me:$LINENO: result: $ac_cv_header_esd_h" >&5
|
|
+echo "${ECHO_T}$ac_cv_header_esd_h" >&6
|
|
+
|
|
+fi
|
|
+if test $ac_cv_header_esd_h = yes; then
|
|
+ ESDHDR=1
|
|
+fi
|
|
+
|
|
+
|
|
+ echo "$as_me:$LINENO: checking for ESD sound support" >&5
|
|
+echo $ECHO_N "checking for ESD sound support... $ECHO_C" >&6
|
|
+ if test "${ESDHDR}z" != "z"; then
|
|
+ HAS_ESD=1
|
|
+
|
|
+ echo "$as_me:$LINENO: result: yes" >&5
|
|
+echo "${ECHO_T}yes" >&6
|
|
+ else
|
|
+ echo "$as_me:$LINENO: result: no" >&5
|
|
+echo "${ECHO_T}no" >&6
|
|
+ fi
|
|
+fi
|
|
+
|
|
+
|
|
+
|
|
# Check whether --enable-sunaudio or --disable-sunaudio was given.
|
|
if test "${enable_sunaudio+set}" = set; then
|
|
enableval="$enable_sunaudio"
|
|
@@ -4239,6 +4239,146 @@
|
|
BSDVIDEOHDR=1
|
|
fi
|
|
|
|
+ if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
|
|
+ echo "$as_me:$LINENO: checking for dev/bktr/ioctl_meteor.h" >&5
|
|
+echo $ECHO_N "checking for dev/bktr/ioctl_meteor.h... $ECHO_C" >&6
|
|
+if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
|
|
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
+fi
|
|
+echo "$as_me:$LINENO: result: $ac_cv_header_dev_bktr_ioctl_meteor_h" >&5
|
|
+echo "${ECHO_T}$ac_cv_header_dev_bktr_ioctl_meteor_h" >&6
|
|
+else
|
|
+ # Is the header compilable?
|
|
+echo "$as_me:$LINENO: checking dev/bktr/ioctl_meteor.h usability" >&5
|
|
+echo $ECHO_N "checking dev/bktr/ioctl_meteor.h usability... $ECHO_C" >&6
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+$ac_includes_default
|
|
+#include <dev/bktr/ioctl_meteor.h>
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ ac_header_compiler=yes
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ac_header_compiler=no
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
|
|
+echo "${ECHO_T}$ac_header_compiler" >&6
|
|
+
|
|
+# Is the header present?
|
|
+echo "$as_me:$LINENO: checking dev/bktr/ioctl_meteor.h presence" >&5
|
|
+echo $ECHO_N "checking dev/bktr/ioctl_meteor.h presence... $ECHO_C" >&6
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#include <dev/bktr/ioctl_meteor.h>
|
|
+_ACEOF
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
|
|
+ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } >/dev/null; then
|
|
+ if test -s conftest.err; then
|
|
+ ac_cpp_err=$ac_c_preproc_warn_flag
|
|
+ ac_cpp_err=$ac_cpp_err$ac_c_werror_flag
|
|
+ else
|
|
+ ac_cpp_err=
|
|
+ fi
|
|
+else
|
|
+ ac_cpp_err=yes
|
|
+fi
|
|
+if test -z "$ac_cpp_err"; then
|
|
+ ac_header_preproc=yes
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ ac_header_preproc=no
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_ext
|
|
+echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
|
|
+echo "${ECHO_T}$ac_header_preproc" >&6
|
|
+
|
|
+# So? What about this header?
|
|
+case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
|
|
+ yes:no: )
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the compiler's result" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the compiler's result" >&2;}
|
|
+ ac_header_preproc=yes
|
|
+ ;;
|
|
+ no:yes:* )
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: present but cannot be compiled" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: present but cannot be compiled" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: check for missing prerequisite headers?" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: check for missing prerequisite headers?" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: see the Autoconf documentation" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: see the Autoconf documentation" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the preprocessor's result" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the preprocessor's result" >&2;}
|
|
+ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: in the future, the compiler will take precedence" >&5
|
|
+echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: in the future, the compiler will take precedence" >&2;}
|
|
+ (
|
|
+ cat <<\_ASBOX
|
|
+## ------------------------------------------ ##
|
|
+## Report this to the AC_PACKAGE_NAME lists. ##
|
|
+## ------------------------------------------ ##
|
|
+_ASBOX
|
|
+ ) |
|
|
+ sed "s/^/$as_me: WARNING: /" >&2
|
|
+ ;;
|
|
+esac
|
|
+echo "$as_me:$LINENO: checking for dev/bktr/ioctl_meteor.h" >&5
|
|
+echo $ECHO_N "checking for dev/bktr/ioctl_meteor.h... $ECHO_C" >&6
|
|
+if test "${ac_cv_header_dev_bktr_ioctl_meteor_h+set}" = set; then
|
|
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
+else
|
|
+ ac_cv_header_dev_bktr_ioctl_meteor_h=$ac_header_preproc
|
|
+fi
|
|
+echo "$as_me:$LINENO: result: $ac_cv_header_dev_bktr_ioctl_meteor_h" >&5
|
|
+echo "${ECHO_T}$ac_cv_header_dev_bktr_ioctl_meteor_h" >&6
|
|
+
|
|
+fi
|
|
+if test $ac_cv_header_dev_bktr_ioctl_meteor_h = yes; then
|
|
+ BSDVIDEOHDR=1
|
|
+fi
|
|
|
|
if test "${ac_cv_header_dev_ic_bt8xx_h+set}" = set; then
|
|
echo "$as_me:$LINENO: checking for dev/ic/bt8xx.h" >&5
|
|
@@ -5872,6 +6065,7 @@
|
|
s,@EGREP@,$EGREP,;t t
|
|
s,@HAS_ALSA@,$HAS_ALSA,;t t
|
|
s,@HAS_OSS@,$HAS_OSS,;t t
|
|
+s,@HAS_ESD@,$HAS_ESD,;t t
|
|
s,@HAS_SUNAUDIO@,$HAS_SUNAUDIO,;t t
|
|
s,@HAS_V4L@,$HAS_V4L,;t t
|
|
s,@HAS_V4L2@,$HAS_V4L2,;t t
|