freebsd-ports/textproc/clucene/files/patch-src__contribs-lib__CMakeLists.txt
Jung-uk Kim 5294672175 - Re-assign textproc/clucene maintainship to office@. [1]
- Update textproc/clucene to 2.3.3.4.  Note this version is required by
recent LibreOffice.
- Remove textproc/clucene-contrib because it is now integrated into
textproc/clucene. [2]
- Mark textproc/p5-Lucene as broken.  There is no dependent port and it was
only written for obsolete Lucene 0.9.x API. [3]
- Update deskutils/kdepim4 and deskutils/strigi to build with the new
CLucene port. [4]
- Update misc/bibletime and misc/sword to use new CLucene 2.3.x API. [5]

Approved by:	clsung (maintainer timeout) [1]
Approved by:	tj (maintainer) [2]
Approved by:	perl [3]
Approved by:	kde [4]
Approved by:	tabthorpe (maintainer timeout) [5]
Obtained from:	The SWORD Project [5]
2013-01-28 22:25:05 +00:00

29 lines
993 B
Text

--- src/contribs-lib/CMakeLists.txt.orig 2011-03-16 20:21:07.000000000 -0400
+++ src/contribs-lib/CMakeLists.txt 2012-08-07 16:27:55.000000000 -0400
@@ -106,9 +106,26 @@
)
TARGET_LINK_LIBRARIES(clucene-contribs-lib ${clucene_contrib_extra_libs})
+#install public headers.
+FOREACH(file ${HEADERS})
+ get_filename_component(apath ${file} PATH)
+ get_filename_component(aname ${file} NAME)
+ file(RELATIVE_PATH relpath ${CMAKE_SOURCE_DIR}/src/contribs-lib ${apath})
+ IF ( NOT aname MATCHES "^_.*" )
+ install(FILES ${file}
+ DESTINATION include/${relpath}
+ COMPONENT development)
+ ENDIF ( NOT aname MATCHES "^_.*" )
+ENDFOREACH(file)
+
#set properties on the libraries
SET_TARGET_PROPERTIES(clucene-contribs-lib PROPERTIES
VERSION ${CLUCENE_VERSION}
SOVERSION ${CLUCENE_SOVERSION}
COMPILE_DEFINITIONS_DEBUG _DEBUG
)
+
+#and install library
+install(TARGETS clucene-contribs-lib
+ DESTINATION ${LIB_DESTINATION}
+ COMPONENT runtime )