freebsd-ports/net/spread4/files/patch-auth-ip.c
Edwin Groothuis 12f56a38a7 [MAINTAINER UPDATE] New versions of spread, spread-j and py-spreadmodule
* Use more bsd.port.mk convenience switches.
* Use rc.subr properly for spread daemon.
* Write a logfile rather than spewing to stdio.
* Move rendezvous socket to /var/run.
* Make Makefile.PL behave properly with PREFIX.

PR:             ports/60053
Submitted by:	Joshua Goodall <joshua@roughtrade.net>
2003-12-29 06:21:20 +00:00

17 lines
910 B
C

--- auth-ip.c Sun Sep 22 12:56:52 2002
+++ auth-ip.c Tue Aug 5 21:27:40 2003
@@ -90,12 +90,9 @@
/* load spread.access_ip file */
if (NULL != (fp = fopen(file_name,"r")) )
Alarm( PRINT, "ip_init: using file: %s\n", file_name);
- if (fp == NULL)
- if (NULL != (fp = fopen("./spread.access_ip", "r")) )
- Alarm( PRINT, "ip_init: using file: ./spread.access_ip\n");
if (fp == NULL)
- if (NULL != (fp = fopen("/etc/spread.access_ip", "r")) )
- Alarm( PRINT, "ip_init: using file: /etc/spread.access_ip\n");
+ if (NULL != (fp = fopen(SPREAD_ETCDIR "/spread.access_ip", "r")) )
+ Alarm( PRINT, "ip_init: using file: " SPREAD_ETCDIR "/spread.access_ip\n");
if (fp == NULL)
{
Alarm( PRINT, "ip_init: IP access control file not found.\nIf you are using IP based access controls, please make sure the file exists.\n");