fcba893850
Changelog: https://cmake.org/cmake/help/v3.14/release/3.14.html Local patches: fixes for Boost, Python, and OpenMP Affected ports: - opencpn, hugin needed help in finding wx - kadu is over-enthusiastic in finding non-existent X11 components - xlife++ does weird things in parsing help output from cmake Thanks antoine@ for multiple exp-runs. Thanks tcberner@ for much prep-work. PR: 236534 223678 227428
11 lines
449 B
Text
11 lines
449 B
Text
--- plugins/screenshot/CMakeLists.txt.orig 2019-03-30 14:44:31 UTC
|
|
+++ plugins/screenshot/CMakeLists.txt
|
|
@@ -30,7 +30,7 @@ set (CONFIGURATION_FILES
|
|
|
|
if (UNIX AND NOT APPLE)
|
|
set (PLUGIN_ADDITIONAL_QT_MODULES X11Extras)
|
|
- find_package (X11 REQUIRED COMPONENTS X11 Xext Xshape)
|
|
+ find_package (X11 REQUIRED COMPONENTS Xext Xshape)
|
|
if (X11_Xshape_FOUND)
|
|
message (STATUS "Found required X11 libraries: ${X11_X11_LIB};${X11_Xext_LIB}")
|
|
else ()
|