1. A fix for patch-i76141, missing libxml2 patch. libxmlsec part is now reordered correctly [1]. 2. Remove patch-i65462 and add patch from i76159 instead [1]. 3. DISTDIR is moved to openoffice.org2 instead of openoffice.org2.0 [1]. 4. FreeBSD bridge part should sync with sixtyfour11. patch-i76969 [1]. 5. unxfbsd.mk: sync with newer unxlngi6.mk. patch-i76969 [1]. 6. Add a new knob WITH_VBA, enables VBA interop. 7. Use gcc4.2 for build. 8. Remove WITH_GNUGCJ knob for while. 9. Drop amd64 for while. Submitted by: jkim [1]
40 lines
1.4 KiB
Text
40 lines
1.4 KiB
Text
Index: solenv/inc/unxfbsd.mk
|
|
===================================================================
|
|
RCS file: /cvs/tools/solenv/inc/unxfbsd.mk,v
|
|
retrieving revision 1.3
|
|
diff -u -r1.3 unxfbsd.mk
|
|
--- solenv/inc/unxfbsd.mk 9 Mar 2007 09:07:55 -0000 1.3
|
|
+++ solenv/inc/unxfbsd.mk 4 May 2007 16:22:53 -0000
|
|
@@ -121,12 +121,6 @@
|
|
# Compiler flags for debugging
|
|
CFLAGSDEBUG=-g
|
|
CFLAGSDBGUTIL=
|
|
-# Compiler flags for enabling optimizations
|
|
-.IF "$(PRODUCT)"!=""
|
|
-CFLAGSOPT=-Os -fno-strict-aliasing # optimizing for products
|
|
-.ELSE # "$(PRODUCT)"!=""
|
|
-CFLAGSOPT= # no optimizing for non products
|
|
-.ENDIF # "$(PRODUCT)"!=""
|
|
# Compiler flags for disabling optimizations
|
|
CFLAGSNOOPT=-O0
|
|
# Compiler flags for describing the output path
|
|
Index: solenv/inc/unxfbsdi.mk
|
|
===================================================================
|
|
RCS file: /cvs/tools/solenv/inc/unxfbsdi.mk,v
|
|
retrieving revision 1.24
|
|
diff -u -r1.24 unxfbsdi.mk
|
|
--- solenv/inc/unxfbsdi.mk 19 Jul 2006 09:27:04 -0000 1.24
|
|
+++ solenv/inc/unxfbsdi.mk 4 May 2007 16:22:53 -0000
|
|
@@ -43,5 +43,12 @@
|
|
# exporting the variable ARCH_FLAGS="..." in the shell, which is used to start build
|
|
ARCH_FLAGS*=-mtune=pentiumpro
|
|
|
|
+# Compiler flags for enabling optimizations
|
|
+.IF "$(PRODUCT)"!=""
|
|
+CFLAGSOPT=-Os -fno-strict-aliasing # optimizing for products
|
|
+.ELSE # "$(PRODUCT)"!=""
|
|
+CFLAGSOPT= # no optimizing for non products
|
|
+.ENDIF # "$(PRODUCT)"!=""
|
|
+
|
|
# platform specific identifier for shared libs
|
|
DLLPOSTFIX=fi
|