freebsd-ports/www/suphp/files/patch-src::apache::Makefile.in
Edwin Groothuis ba63502f38 [update] www/suphp: update to 0.3 and fix a security leak introduced with previous patch
- update to 0.3
	- add a workaround to don't use getpwuid to performs check for apache user (since 4.x
	  doesn't support getpwuid_r).
	- use %%DOCSDIR%%

PR:		ports/55952
Submitted by:	Clement Laforet <sheepkiller@cultdeadsheep.org>
2003-08-25 12:13:36 +00:00

13 lines
412 B
Text

--- src/apache/Makefile.in.orig Mon Aug 25 11:40:47 2003
+++ src/apache/Makefile.in Mon Aug 25 11:41:02 2003
@@ -29,7 +29,9 @@
all: suphp.mod
suphp.mod: mod_suphp.c
- $(APXS) -c $(DEFS) $(EXTRADEFS) $(INCLUDES) -Wc,"$(CFLAGS)" mod_suphp.c
+ @if [ ! -f mod_suphp.o ]; then \
+ $(APXS) -c $(DEFS) $(EXTRADEFS) $(INCLUDES) -Wc,"$(CFLAGS)" mod_suphp.c ;\
+ fi;
install: suphp.mod
$(APXS) -i -a mod_suphp.so