freebsd-ports/x11-toolkits/fltk/files/patch-documentation_Makefile
Alexey Dokuchaev 0ebb290638 - Fix the breakage caused by previous commit (r378707): restore sane order of
knobs; resurrect documentation/Makefile patch; bring back recalculation of
  ${ETCDIR} length in Fl_Preferences.cxx, trim CONFIGURE_ARGS (again), etc.
- Restore correct LDFLAGS+= -L../src (previously -L${WRKSRC}/src), otherwise
  the build fails with e.g. previous version of FLTK libraries installed
- Take maintainership to prevent Kato's monkeys jeopardizing it all over again
- Install code examples as PORTEXAMPLES (we do not install any documentation
  because it requires LaTeX stack to build)
- Since `post-patch' target is a bit too verbose now, make it .SILENT
- Do not compile things with -Os by default (already honors user's CXXFLAGS)
- Do not blindly strip libraries and fluid(1) binary (respect ${STRIP} value)
2015-02-09 08:50:02 +00:00

23 lines
1.1 KiB
Text

--- documentation/Makefile.orig 2011-08-27 01:33:42.000000000 +0000
+++ documentation/Makefile 2011-08-27 01:39:59.000000000 +0000
@@ -73,7 +73,7 @@
install: $(MANPAGES)
echo "Installing documentation files in $(DESTDIR)$(docdir) ..."
- -$(INSTALL_DIR) $(DESTDIR)$(docdir)
+# -$(INSTALL_DIR) $(DESTDIR)$(docdir)
if test -f html/index.html ; then \
for file in html/* ; do \
$(INSTALL_DATA) $$file $(DESTDIR)$(docdir); \
@@ -84,11 +84,6 @@
$(INSTALL_DATA) fltk.pdf $(DESTDIR)$(docdir); \
fi
echo "Installing man pages in $(DESTDIR)$(mandir) ..."
- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat1
- $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat3
- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
-$(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
$(INSTALL_MAN) $(SRC_DOCDIR)/fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
$(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1