Both textproc/raptor and textproc/raptor2 provide a raptor.h header; the former puts it in ${LOCALBASE}/include, whereas the latter puts it into ${LOCALBASE}/include/raptor2. The way CPPFLAGS and LDFLAGS were changed so far, -I${LOCALBASE}/include was passed to the compiler before -I${LOCALBASE}/include/raptor2, so the raptor1 headers were picked up and the build failed. The fix is consists of several separate adjustments: - The port only depends on raptor2 (and obtains the required compiler and linker flags via pkg-config) and optionally on OpenSSL from ports in case one has installed it. We thus need USE_OPENSSL and OPENSSLINC/OPENSSLLIB. - Due to the other the CFLAGS are defined in the port's configure.ac, we need to make raptor2's CFLAGS be passed before the rest, so -I${LOCALBASE}/include/raptor2 is passed to the compiler before other paths such as the infamous ${LOCALBASE}/include. - We need to change CFLAGS instead of CPPFLAGS, otherwise the OpenSSL CFLAGS still come before the actual CFLAGS and the problem persists.
13 lines
390 B
Text
13 lines
390 B
Text
--- configure.ac~ 2012-08-22 17:58:12.000000000 -0300
|
|
+++ configure.ac 2012-08-22 17:58:36.000000000 -0300
|
|
@@ -34,8 +34,8 @@
|
|
AC_FUNC_VPRINTF
|
|
AC_CHECK_FUNCS([getcwd strcasecmp strchr strdup strerror strncasecmp strrchr])
|
|
|
|
-LIBS="$LIBS $RAPTOR_LIBS"
|
|
-AM_CFLAGS="$CFLAGS $RAPTOR_CFLAGS"
|
|
+LIBS="$RAPTOR_LIBS $LIBS"
|
|
+AM_CFLAGS="$RAPTOR_CFLAGS $CFLAGS"
|
|
|
|
AC_SUBST(AM_CFLAGS)
|
|
AC_SUBST(LIBS)
|