freebsd-ports/print/ghostscript8-base/files/patch-epag-ert.c
Hiroki Sato 27470e1676 - Split ghostscript into X11-independent and -dependent parts:
* print/ghostscript{7,8,9,9-agpl}-base

   Installs Ghostscript binary, libgs, and related files.
   These ports do not depend on X11 libraries (i.e. x11* devices
   are not available).  USES=ghostscript will set dependency on
   one of them depending on GHOSTSCRIPT_DEFAULT.

   The default device is set to "display" or "bbox".

 * print/ghostscript{7,8,9,9-agpl}-x11

   Installs a shared library which provides X11 support to
   the installed Ghostscript binaries.  x11* devices will be
   enabled when the library is available.

   This depends on *-base (RUN_DEPENDS).  USES=ghostscript:x11
   will set dependency on one of them.

- Fix integer overflow reported as CVE-2015-3228.

- Update Uses/ghostscript.mk:

 * Add x11 keyword.  nox11 keyword is now obsolete.

 * Use packagename in *_DEPENDS line to prevent relationship between
   -base and -x11 packages from being broken.

- Fix x11/nox11 keyword and bump PORTREVISION in ports using
  USES=ghostscript to update dependency of pre-compiled packages.
2015-08-22 17:48:35 +00:00

11 lines
298 B
C

--- epag-3.09/ert.c.orig 2000-07-08 13:33:09.000000000 +0900
+++ epag/ert.c 2012-02-13 03:38:07.000000000 +0900
@@ -1,6 +1,8 @@
/* $Id: ert.c,v 1.3 1998/11/20 10:51:12 nari Exp $ */
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
/*
* EPSON Remoteのコマンドを出力するコマンド